summaryrefslogtreecommitdiff
path: root/dev-python/tavern/tavern-2.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-15 23:49:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-15 23:49:15 +0100
commitfddb33ccaadabe03f5571606f796b45965b38e9c (patch)
treedba6d179254abac3ee319d7bde5191bebf09a5c3 /dev-python/tavern/tavern-2.0.7.ebuild
parent6fc112778f70ed827633ff345036db5b592ca1d0 (diff)
gentoo auto-resync : 15:04:2023 - 23:49:14
Diffstat (limited to 'dev-python/tavern/tavern-2.0.7.ebuild')
-rw-r--r--dev-python/tavern/tavern-2.0.7.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/tavern/tavern-2.0.7.ebuild b/dev-python/tavern/tavern-2.0.7.ebuild
new file mode 100644
index 000000000000..d056f7b90089
--- /dev/null
+++ b/dev-python/tavern/tavern-2.0.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool, library, and Pytest plugin for testing RESTful APIs"
+HOMEPAGE="
+ https://github.com/taverntesting/tavern/
+ https://pypi.org/project/tavern/
+"
+SRC_URI="
+ https://github.com/taverntesting/tavern/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/paho-mqtt[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/pykwalify[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/python-box[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/Faker[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # strip unnecessary pins, upstream doesn't update them a lot
+ sed -i -E -e 's:,?<=?[0-9.]+::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -p tavern
+}