summaryrefslogtreecommitdiff
path: root/dev-python/sympy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-09 00:01:03 +0100
commita0ce545d52f231499bf9f3644493113d8af58ec9 (patch)
tree4d67c09eed0c2ae28d1317f72d7f7b08b4f6aeea /dev-python/sympy
parent5181ced3f3566a9610b85922b083c8f84f20d78f (diff)
gentoo auto-resync : 09:05:2024 - 00:01:03
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest2
-rw-r--r--dev-python/sympy/sympy-1.12.1_rc1.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index e95ea8abc2bc..c0f4ff66aba8 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,5 +1,7 @@
AUX sympy-1.12-c99.patch 1666 BLAKE2B 3b60410c635cd55935108776e827cca2cafc2b16b2a1bb8a43a1a811829b7a3d1e9f72ed5c7bb312c0200d1d27b2a14a41633983a31a89af35c0b7491e9a01b1 SHA512 d4377b544183cf44e3942fcbcc8e0b474a75eb8892df94c6ed5c8f3fd3aae52972ce07ab5ec501476860bef806bf8358a95fd28ccddf942f33d5520a3c9bc2fe
AUX sympy-1.12-py312.patch 1543 BLAKE2B 786e7f2934adf9d30c21f5fa807910507bddebbffc2c2d91a80e48b9767d340490f459df08a61c2b9f7d5d48342a24ac2c40673ed63a531d0c83ddea1773985c SHA512 e6359b32f9949b8412e9af1183e7cf2c7e888a83a15876f0fb370a3e671b993ef0b524e103aa6eff29e11a33b0ce44fc8e3d2e53c61042924130738678188bab
+DIST sympy-1.12.1rc1.gh.tar.gz 8009898 BLAKE2B 7afbcb0c17249509a1a780bdfbe72eee5aaa4b4548a587968bd2c454cbdbda9e81b47ee31c98a8aa2323d575a9cc8897f9b52aba0eec1ed831e3038b2fc15aff SHA512 575947bc1057d8bfb5e4d6f84243d0206449ef97d861e6029c11f0868c34b8d909159901054469738577edc8f941db14a61936402037a24153c1ca97af4758ad
DIST sympy-1.12.gh.tar.gz 7212937 BLAKE2B 1d37a019e7a6700e69e16d6ca7fdc563711165fc226ac6ec745d20fa6dc689ee9ea01a92549d851aacff763230872c2d1d0cb5bde581c4f960f5de515ffb5f06 SHA512 96a89b88f6912d70c56f5bd1903dd3c518963118ff25d033cdcb7da2f260b8ee209d3ab4a4394dd2b5dc0b4585b71ccd55d55c8e5c6e28024cccbedf07ee4360
EBUILD sympy-1.12-r1.ebuild 3227 BLAKE2B 61098074c5ae664a5a6185ae4bfb1ee4e6bb5d40a8ebb02487419a096d57826a04aad64542b0660b6bc76ad9c7d6a949bef29c88ca9d55144ae5ce79339f309f SHA512 d1814458cc2b462fb20baf9cb00e1720e224df5b2ef1dd68de1815c64223e73f6e14b647a5cdbf2a3d93b996c1d7eb83a38ae73cf8b42156ceb95e0d15735aa6
+EBUILD sympy-1.12.1_rc1.ebuild 3002 BLAKE2B dd32845cfe569557515e0e9b91fb0c2052ba1cd925517e7f00bcae6a700e37777e898b803cbf41b8736a0e8f9231f529465b0ce6eea76c54ff8a3d05fe7f90d2 SHA512 039799457c56844410fcc426e918e7ae685a736feeebaa04239bac7a2f36ea4928d1cb63157c712ef507e84acb3754f8efcae76a2c5ba581e2007e35d53aa900
MISC metadata.xml 1722 BLAKE2B 09837a8e4ed0d70cf62a2e5028d480ffd7d15d821220c771dec04380e9707da56625651a49ac656a7de27ee3e8f395091abe763d2d3c59cfe32bf363cdba60cf SHA512 fad83c852dd953709e20056b0da38a0f0504bc70a99d9a9fbf295d98ed462811ee6fcf755d5ad1aeb515fd62fafe35a609f6d2892af2ed921870b6f5c38edc5f
diff --git a/dev-python/sympy/sympy-1.12.1_rc1.ebuild b/dev-python/sympy/sympy-1.12.1_rc1.ebuild
new file mode 100644
index 000000000000..b5b261a645c7
--- /dev/null
+++ b/dev-python/sympy/sympy-1.12.1_rc1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="
+ https://www.sympy.org/
+ https://github.com/sympy/sympy/
+ https://pypi.org/project/sympy/
+"
+# pypi sdist misses some files, notably top-level conftest.py, as of 1.12.1_rc1
+SRC_URI="
+ https://github.com/sympy/sympy/archive/${PV/_/}.tar.gz
+ -> ${P/_/}.gh.tar.gz
+"
+S=${WORKDIR}/${P/_/}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="aesara examples imaging ipython latex mathml opengl pdf png pyglet symengine texmacs"
+
+RDEPEND="
+ dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ aesara? (
+ $(python_gen_cond_dep '
+ dev-python/aesara[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ )
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-python/lxml[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require old version of antlr4
+ sympy/parsing/tests/test_autolev.py
+ sympy/parsing/tests/test_latex.py
+ # crash due to assertions in sys-devel/llvm[debug]
+ sympy/parsing/tests/test_c_parser.py
+
+ # TODO: pytest?
+ sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_check
+ sympy/solvers/ode/tests/test_systems.py::test_linear_3eq_order1_type4_long_dsolve_dotprodsimp
+
+ # either very slow or hanging
+ sympy/solvers/ode/tests/test_systems.py::test_linear_new_order1_type2_de_lorentz_slow_check
+ sympy/integrals/tests/test_failing_integrals.py::test_issue_15227
+ sympy/matrices/tests/test_matrices.py::test_pinv_rank_deficient_when_diagonalization_fails
+ sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type1
+ sympy/solvers/ode/tests/test_systems.py::test_nonlinear_3eq_order1_type3
+
+ # known broken
+ # https://github.com/sympy/sympy/issues/26321
+ sympy/solvers/tests/test_simplex.py::test_lp
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest --veryquickcheck ||
+ die -n "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}