summaryrefslogtreecommitdiff
path: root/dev-python/sybil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-18 05:38:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-18 05:38:53 +0000
commit3e4b97f04e1561890eb4b0bcb3a411b931c08d02 (patch)
treed34aa692c74eb0e0de725fa00b6df5785268b52c /dev-python/sybil
parent78fce155315439a69aa67573fd4696b735649431 (diff)
gentoo auto-resync : 18:02:2024 - 05:38:53
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest3
-rw-r--r--dev-python/sybil/files/sybil-6.0.2-pytest-8.patch40
-rw-r--r--dev-python/sybil/sybil-6.0.2-r1.ebuild44
3 files changed, 0 insertions, 87 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 4e76e7087e84..95bee7bcb980 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,6 +1,3 @@
-AUX sybil-6.0.2-pytest-8.patch 2027 BLAKE2B c71742c315b0195a5984a40b399e071f648c9c5a688f3099d2a8771f01c946ae9074be307793055235225364330b72d7e00b27c03a3c94f0a56d316c60fc6b3a SHA512 f9c237aea2c498d3df076b011a377983344ad03b89e2f11146f13216d38157795f67f2afd78bf714ffbce2902d73caf1a79e01409738d92d8f3df4ee97761fa1
-DIST sybil-6.0.2.gh.tar.gz 67619 BLAKE2B ec723cb21d2ac1232bd6e9a3e3edb0bc65c705048c2d288df778b4dd19a1b46c956f7d2bd57dfa028d7a8a06357501ffc1226ba171e2073abec51f8d3c536d86 SHA512 9966173b5fb013be1f298b586052d8c10b76efb43bf5230f3d0b780e6d6238e7e33840eeb7c8b9860911351ea612766ed19ea2a61d48424465f3b58e408da5d2
DIST sybil-6.0.3.gh.tar.gz 67772 BLAKE2B e90b7a01373d931ca056bfce1336bab8a579a25e17000675d77cd849081275970b455c7bc77f30e0fd104073115915fc4f4477b010eafd35e57aec322fb42fc4 SHA512 1fb42b944b237556012ace6fcc5eb3d0f067f0ca043ceafa0e201a8076870fc7e06ae62813eec90d486de6e4b71ebf29176dfff6573de423480c688ff005004d
-EBUILD sybil-6.0.2-r1.ebuild 901 BLAKE2B 559ec680a63f7a095b352808370bf04950ea23f683f0a4800a8dc3468a6c19f2ad5e90811daad2d60217b04a31c115782cafefc933e254b67acdb8f990ca682e SHA512 d58e428155a5727391159e7e500c405ab2705fcb93416127aad3360abaaa79ebadb64768a0568358bda4e1740cd46d873862c7301eb82673183a46c2ffe6ef79
EBUILD sybil-6.0.3.ebuild 805 BLAKE2B b5b462092167aa4c09502e079c2c4d0e5a40a0d58bf6519b95d3c6b11c916eea33b9a274286c4c2f26b40b7e4d9741e654059811b1f2ec144f75f9ac0a85c0b4 SHA512 89d342e7f9d38e061f0fd8b8c30a1d57c5ddc21ef166ba0b7e8049c9cf39dff93ccef98bec302a7d84d9e25d147777fe6f784798a6f476625fd4fa04a16d3f2c
MISC metadata.xml 402 BLAKE2B 3fcce3ac9ff731e24a3f6e761da2d840b3a7c9107b3d9a46afe00fed61b475d1400580b4ccf49dd71f6a1ab8098dc2aaf895e529a723cd96301d1400ee211edf SHA512 138106c714dc33871ccf535cc47d669580b665c842adfea5442a03067fe507236d8fde4158f006e1188003abe53c9c25db98632dadd1cfa0e41efd1755c2c75c
diff --git a/dev-python/sybil/files/sybil-6.0.2-pytest-8.patch b/dev-python/sybil/files/sybil-6.0.2-pytest-8.patch
deleted file mode 100644
index 2447289c0266..000000000000
--- a/dev-python/sybil/files/sybil-6.0.2-pytest-8.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From d7428b4cfe5f817037030d025028bf09fd7992ee Mon Sep 17 00:00:00 2001
-From: Adam Dangoor <adamdangoor@gmail.com>
-Date: Mon, 29 Jan 2024 11:29:16 +0000
-Subject: [PATCH] Add fixes for Pytest 8.0.0
-
----
- CHANGELOG.rst | 5 +++++
- sybil/integration/pytest.py | 17 +++++++++++++----
- 2 files changed, 18 insertions(+), 4 deletions(-)
-
-diff --git a/sybil/integration/pytest.py b/sybil/integration/pytest.py
-index 8ce6c72..cad311d 100644
---- a/sybil/integration/pytest.py
-+++ b/sybil/integration/pytest.py
-@@ -53,12 +53,21 @@ def __init__(self, parent, sybil, example: Example) -> None:
- def request_fixtures(self, names):
- # pytest fixtures dance:
- fm = self.session._fixturemanager
-- closure = fm.getfixtureclosure(names, self)
-- initialnames, names_closure, arg2fixturedefs = closure
-- fixtureinfo = FuncFixtureInfo(names, initialnames, names_closure, arg2fixturedefs)
-+ if PYTEST_VERSION >= (8, 0, 0):
-+ closure = fm.getfixtureclosure(initialnames=names, parentnode=self, ignore_args=set())
-+ names_closure, arg2fixturedefs = closure
-+ fixtureinfo = FuncFixtureInfo(argnames=names, initialnames=names, names_closure=names_closure, name2fixturedefs=arg2fixturedefs)
-+ else:
-+ closure = fm.getfixtureclosure(names, self)
-+ initialnames, names_closure, arg2fixturedefs = closure
-+ fixtureinfo = FuncFixtureInfo(names, initialnames, names_closure, arg2fixturedefs)
- self._fixtureinfo = fixtureinfo
- self.funcargs = {}
-- self._request = fixtures.FixtureRequest(self, _ispytest=True)
-+ if PYTEST_VERSION >= (8, 0, 0):
-+ self._request = fixtures.TopRequest(pyfuncitem=self, _ispytest=True)
-+ self.fixturenames = names_closure
-+ else:
-+ self._request = fixtures.FixtureRequest(self, _ispytest=True)
-
- def reportinfo(self) -> Tuple[Union["os.PathLike[str]", str], Optional[int], str]:
- info = '%s line=%i column=%i' % (
diff --git a/dev-python/sybil/sybil-6.0.2-r1.ebuild b/dev-python/sybil/sybil-6.0.2-r1.ebuild
deleted file mode 100644
index 0a280c114202..000000000000
--- a/dev-python/sybil/sybil-6.0.2-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Automated testing for the examples in your documentation"
-HOMEPAGE="
- https://github.com/simplistix/sybil/
- https://pypi.org/project/sybil/
-"
-# tests are missing in sdist, as of 5.0.1
-SRC_URI="
- https://github.com/simplistix/sybil/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-BDEPEND="
- test? (
- dev-python/myst-parser[${PYTHON_USEDEP}]
- dev-python/seedir[${PYTHON_USEDEP}]
- dev-python/testfixtures[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/simplistix/sybil/pull/108
- "${FILESDIR}/${P}-pytest-8.patch"
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}