summaryrefslogtreecommitdiff
path: root/dev-python/sybil/sybil-6.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-23 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-23 23:59:27 +0100
commite3f21c8aff8a76afe3423721c437a088e9232840 (patch)
treefde2c1906a9787adec106c5d6b708cd60de02c60 /dev-python/sybil/sybil-6.1.0.ebuild
parent1f00990debeffd0052c194989d0a02baac23eb96 (diff)
gentoo auto-resync : 23:04:2024 - 23:59:26
Diffstat (limited to 'dev-python/sybil/sybil-6.1.0.ebuild')
-rw-r--r--dev-python/sybil/sybil-6.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sybil/sybil-6.1.0.ebuild b/dev-python/sybil/sybil-6.1.0.ebuild
new file mode 100644
index 000000000000..adf69fd38724
--- /dev/null
+++ b/dev-python/sybil/sybil-6.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}