summaryrefslogtreecommitdiff
path: root/dev-python/svglib/svglib-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/svglib/svglib-1.2.1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/svglib/svglib-1.2.1.ebuild')
-rw-r--r--dev-python/svglib/svglib-1.2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/svglib/svglib-1.2.1.ebuild b/dev-python/svglib/svglib-1.2.1.ebuild
new file mode 100644
index 000000000000..b14fdc7c368f
--- /dev/null
+++ b/dev-python/svglib/svglib-1.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python library for reading and converting SVG"
+HOMEPAGE="https://pypi.org/project/svglib/ https://github.com/deeplook/svglib"
+SRC_URI="
+ https://github.com/deeplook/svglib/archive/v.${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-v.${PV}
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cssselect2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs network access
+ tests/test_samples.py::TestWikipediaFlags::test_convert_pdf
+ tests/test_samples.py::TestW3CSVG::test_convert_pdf_png
+)