summaryrefslogtreecommitdiff
path: root/dev-python/svg-path/svg-path-6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-30 11:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-30 11:17:10 +0100
commit200338d9ebd0cd0599af59f208eb58f48f5ae168 (patch)
tree03aa7ba96612219b7aeb018639ba95924c0f1d81 /dev-python/svg-path/svg-path-6.3.ebuild
parenta9a8100d7a659b808e3a112a113b65e16f0070c3 (diff)
gentoo auto-resync : 30:04:2023 - 11:17:09
Diffstat (limited to 'dev-python/svg-path/svg-path-6.3.ebuild')
-rw-r--r--dev-python/svg-path/svg-path-6.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/svg-path/svg-path-6.3.ebuild b/dev-python/svg-path/svg-path-6.3.ebuild
new file mode 100644
index 000000000000..ec37884e84b6
--- /dev/null
+++ b/dev-python/svg-path/svg-path-6.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="SVG path objects and parser"
+HOMEPAGE="
+ https://github.com/regebro/svg.path/
+ https://pypi.org/project/svg.path/
+"
+# no tests in sdist, as of 6.3
+SRC_URI="
+ https://github.com/regebro/svg.path/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest