summaryrefslogtreecommitdiff
path: root/dev-python/svg-path/svg-path-3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/svg-path/svg-path-3.0.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/svg-path/svg-path-3.0.ebuild')
-rw-r--r--dev-python/svg-path/svg-path-3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/svg-path/svg-path-3.0.ebuild b/dev-python/svg-path/svg-path-3.0.ebuild
new file mode 100644
index 000000000000..7856e4825787
--- /dev/null
+++ b/dev-python/svg-path/svg-path-3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="svg.path"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SVG path objects and parser"
+HOMEPAGE="https://github.com/regebro/svg.path"
+SRC_URI="https://github.com/regebro/svg.path/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test || die
+}
+
+python_install() {
+ python_domodule src/svg
+}