summaryrefslogtreecommitdiff
path: root/dev-python/sunpy/sunpy-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/sunpy/sunpy-0.8.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/sunpy/sunpy-0.8.0.ebuild')
-rw-r--r--dev-python/sunpy/sunpy-0.8.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/sunpy/sunpy-0.8.0.ebuild b/dev-python/sunpy/sunpy-0.8.0.ebuild
deleted file mode 100644
index c0c051c1581d..000000000000
--- a/dev-python/sunpy/sunpy-0.8.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Software library for solar physics based on Python"
-HOMEPAGE="https://sunpy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="jpeg2k test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/astropy-2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/suds[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- sci-libs/scikits_image[${PYTHON_USEDEP}]
- jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-mpl[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # use system astropy-helpers instead of bundled one
- sed -i -e '/auto_use/s/True/False/' setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
-}