summaryrefslogtreecommitdiff
path: root/dev-python/suds
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/suds
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/suds')
-rw-r--r--dev-python/suds/Manifest3
-rw-r--r--dev-python/suds/metadata.xml13
-rw-r--r--dev-python/suds/suds-0.6-r1.ebuild54
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/suds/Manifest b/dev-python/suds/Manifest
new file mode 100644
index 000000000000..7d8a37b1d356
--- /dev/null
+++ b/dev-python/suds/Manifest
@@ -0,0 +1,3 @@
+DIST suds-0.6.tar.bz2 143985 BLAKE2B 3d97d51b4e719102ab40a6a95a35eaaccda15a47e20bedb0297203576949883eea253ac6f382c8849a522e1720393ec517ec1ff3514329b504c83a928a260881 SHA512 ec078b159bd83c5799e293d9607138ee1da90fdc64da203999555a4324ce7be0235156d3c7ad28e46f84180a6e51e2f3f82228e5e77ae41c61ee20f3db2c916b
+EBUILD suds-0.6-r1.ebuild 1617 BLAKE2B 1748535cc1e7f4a69688d1bba2569a7bf6efdd90d85773dc13b47a963c82be35dbf8fc2da1f7bac31f51a37b2641f745657be6778070765471ea2202562f3f32 SHA512 e777014e5a342fdec7a7881df9ced1e9a473d26cdc22111dc5c1d6f7de00d4e196d087faa31fec9aac23d969d95373b742fc7bb483743e7c2e2e29a5c4ae1723
+MISC metadata.xml 467 BLAKE2B 0da3f0b6af9a58a5468a019a9dcd1502765097c221a9b90545320c7209260f7d1ce5b2ab8cf495a48dd3867c63a70f68feef01352976feae2cfbaf7d7805fc22 SHA512 b2db05a4b1e5cdebd8132837510bee73355ef88cf2f22ec8ce8c439be5eb6a7d3a3f14639dc7dc9a5a3d99d45ac96a4322b9fcdd97719161b5699602d7b880d2
diff --git a/dev-python/suds/metadata.xml b/dev-python/suds/metadata.xml
new file mode 100644
index 000000000000..caa921209382
--- /dev/null
+++ b/dev-python/suds/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">A lightweight SOAP python client for consuming Web Services.</longdescription>
+ <upstream>
+ <remote-id type="pypi">suds</remote-id>
+ <remote-id type="bitbucket">jurko/suds</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/suds/suds-0.6-r1.ebuild b/dev-python/suds/suds-0.6-r1.ebuild
new file mode 100644
index 000000000000..777c40cd8902
--- /dev/null
+++ b/dev-python/suds/suds-0.6-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client (Jurko's fork) (py3 support) (active development)"
+HOMEPAGE="https://bitbucket.org/jurko/suds"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}-jurko/${PN}-jurko-${PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-jurko-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+REQUIRED_USE="doc? ( $(python_gen_useflags python2_7) )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/epydoc[$(python_gen_usedep python2_7)] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( README.rst notes/{argument_parsing.rst,readme.txt,traversing_client_data.rst} )
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+}
+
+python_compile_all() {
+ # to say that it's both, because it kinda is...
+ ! use doc || epydoc -n "Suds - ${DESCRIPTION}" -o doc suds || die
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ # test folder makes for file collisions by the eclass
+ sed -i -e '/^tests/d' suds_jurko.egg-info/top_level.txt suds_jurko.egg-info/SOURCES.txt || die
+ cp -r suds_jurko.egg-info suds.egg-info || die
+ sed -i -e 's/Name\:\ suds-jurko/Name:\ suds/g' -e '/^Obsoletes/d' suds.egg-info/PKG-INFO || die
+ rm -rf ./{tests,build/lib/tests,lib/tests}/ || die
+ distutils-r1_python_install
+}