summaryrefslogtreecommitdiff
path: root/dev-python/subvertpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/subvertpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/subvertpy')
-rw-r--r--dev-python/subvertpy/Manifest5
-rw-r--r--dev-python/subvertpy/metadata.xml8
-rw-r--r--dev-python/subvertpy/subvertpy-0.10.1.ebuild29
-rw-r--r--dev-python/subvertpy/subvertpy-0.9.1.ebuild39
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/subvertpy/Manifest b/dev-python/subvertpy/Manifest
new file mode 100644
index 000000000000..ff2102be1802
--- /dev/null
+++ b/dev-python/subvertpy/Manifest
@@ -0,0 +1,5 @@
+DIST subvertpy-0.10.1.tar.gz 116661 BLAKE2B 81fdc21352f168c1a8d31398be21ad83ed72adc824dbbca7764fb1836cba4a7d7f03e4a96636ab29f4804682658ce834eea3fd433b5f161e61a702dfc6790e22 SHA512 083174ca6516541c48474673e6d601ff3098f19d204f311101f4de81bcd70d73bdb1e73dffe43fc584f35d286020cab1381dc1c44b514442735a139d2a9cd356
+DIST subvertpy-0.9.1.tar.gz 110972 BLAKE2B 1f11b55b81705b6b144e0c4ac53f2e0e5a847b96bb43589894c8c910492b443d61bfc5bdcbdba1e2bb757fbd587b029d0be113084a45c17aec8c0befdff0e12a SHA512 977e291c011e680cff9e26312b4235c0479374076964c7c4a4c3c7ec75bcc44ff7c458513ab89f1aa2b599d3bd8f94cbc6d1000afcf725a9f937a90b39456148
+EBUILD subvertpy-0.10.1.ebuild 688 BLAKE2B 5485b62521e83a9d5802525bc7b22425af740d2b36c67eef28e5ee8d3518d77f8a48d46ed3790e75f8f8382e9baaccf78db5250edc017c3a9dee4c42f0d24839 SHA512 7efd12f482c84b785b1a4dc5acd949502b709e9a1250c47df1e28d0df7c8e714a6051c41791c5b015d8d554ff1417650daa5a16b68a32efa4d44f52e0966f444
+EBUILD subvertpy-0.9.1.ebuild 982 BLAKE2B 9116b387f4dc040399137790ff568af891c41d4561971b1771dc1e765e58e8460e2a9168e298f911cce9096e44e68528ee7fb54e11901557d808a598f1c010db SHA512 6f50d1971566fca58d4769366b44417915f51482323a913482f9644c4e170d216b6460fd7540c389ab75cf8e837a41dbcd4c13fa20c86ba20847c6078c487462
+MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/dev-python/subvertpy/metadata.xml b/dev-python/subvertpy/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/dev-python/subvertpy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/subvertpy/subvertpy-0.10.1.ebuild b/dev-python/subvertpy/subvertpy-0.10.1.ebuild
new file mode 100644
index 000000000000..0dc9a9a7313e
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.10.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="https://jelmer.uk/code/subvertpy/ https://pypi.org/project/subvertpy"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/subversion-1.4"
+DEPEND="${RDEPEND}
+ dev-libs/apr-util"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test --args=-v
+}
diff --git a/dev-python/subvertpy/subvertpy-0.9.1.ebuild b/dev-python/subvertpy/subvertpy-0.9.1.ebuild
new file mode 100644
index 000000000000..979bff9695a2
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="https://www.samba.org/~jelmer/subvertpy/ https://pypi.org/project/subvertpy/"
+SRC_URI="https://www.samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/subversion-1.4"
+DEPEND="${RDEPEND}
+ test? ( || (
+ dev-python/testtools
+ ) )"
+
+DOCS=( NEWS AUTHORS )
+S=${WORKDIR}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ distutils_install_for_testing
+ pushd man > /dev/null
+ # hack: the subvertpy in . has no compiled modules, so cd into any
+ # directory to give the installed version precedence on PYTHONPATH
+ ${PYTHON} -m unittest subvertpy.tests.test_suite
+ popd man > /dev/null
+}