summaryrefslogtreecommitdiff
path: root/dev-python/subvertpy/subvertpy-0.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/subvertpy/subvertpy-0.9.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/subvertpy/subvertpy-0.9.1.ebuild')
-rw-r--r--dev-python/subvertpy/subvertpy-0.9.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/subvertpy/subvertpy-0.9.1.ebuild b/dev-python/subvertpy/subvertpy-0.9.1.ebuild
new file mode 100644
index 000000000000..dc86dd9ed19d
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/ https://pypi.python.org/pypi/subvertpy"
+SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=">=dev-vcs/subversion-1.4"
+DEPEND="${RDEPEND}
+ test? ( || (
+ dev-python/testtools
+ ) )"
+
+DOCS=( NEWS AUTHORS )
+S=${WORKDIR}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ distutils_install_for_testing
+ pushd man > /dev/null
+ # hack: the subvertpy in . has no compiled modules, so cd into any
+ # directory to give the installed version precedence on PYTHONPATH
+ ${PYTHON} -m unittest subvertpy.tests.test_suite
+ popd man > /dev/null
+}