summaryrefslogtreecommitdiff
path: root/dev-python/stripe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/stripe
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/stripe')
-rw-r--r--dev-python/stripe/Manifest3
-rw-r--r--dev-python/stripe/metadata.xml18
-rw-r--r--dev-python/stripe/stripe-1.66.0.ebuild30
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/stripe/Manifest b/dev-python/stripe/Manifest
new file mode 100644
index 000000000000..eec3c62ba159
--- /dev/null
+++ b/dev-python/stripe/Manifest
@@ -0,0 +1,3 @@
+DIST stripe-1.66.0.tar.gz 191304 SHA256 d9fe9527de58ddcf05b6cfd07c444c43d53811a7fc0d58bd7a82ed4006cdbbc6 SHA512 bb98837a662f36ed4d25f45bfff6614962552abeab1240890c139333064effd911b8cb20c181f54fb540ed5315b98172aebc2785d8bc215ea61d421ad49b1ee5 WHIRLPOOL 8b8ba83a5f109f28e033d1df6157209982a33527b76cf15d7a6ad0c57b928e5778f8785be691db25c5df16b4cfe37e8676f47a270c2a8da6b09bd6da08a95af8
+EBUILD stripe-1.66.0.ebuild 600 SHA256 7cc40d3e81166b31ede7fbffa6b1496c209aeb36881f852f6515690005d9e43f SHA512 d80be59c9ce388abd60ca672a6e08e5ff25281ef1cc80aefc0b94f9a59a35d11d0ce8da0d2a6efedaa71538ed0a5540e667c44f017825f98c4aa7f1bbd424308 WHIRLPOOL 567926b6a77e2e417d9da7803d44b17312f830d66935b3794b4ef2e06c308c8b8fac5e4e2786b42e2f651ec30897fbed60aa6e5a5aa98c3e8b04b178496af658
+MISC metadata.xml 539 SHA256 3d87cd039dea943fe3e0c0eb1cc85ddebde4bee94e9e0f5cf0cbbc5d0660ae90 SHA512 f0052ba8457139d76ddce67313bc973564237b409801d3d6da181c495c2d80184076cbe36468850a1ddcd60de50327e728fc3433a8a4bfe9608713a33fdbe9c1 WHIRLPOOL 41ebfc64a5c8632aa3cb6b78e8df13fa62695a130b2188ed26427babcfb529557df7ee036c37bae94e6ea88d97d28c298816bc2af31ffba8dcd295eaab8397d0
diff --git a/dev-python/stripe/metadata.xml b/dev-python/stripe/metadata.xml
new file mode 100644
index 000000000000..00a5d2222be1
--- /dev/null
+++ b/dev-python/stripe/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <longdescription lang="en">
+ Official Stripe Bindings for Python
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">stripe</remote-id>
+ <remote-id type="github">stripe/stripe-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/stripe/stripe-1.66.0.ebuild b/dev-python/stripe/stripe-1.66.0.ebuild
new file mode 100644
index 000000000000..674033205871
--- /dev/null
+++ b/dev-python/stripe/stripe-1.66.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Stripe python bindings"
+HOMEPAGE="https://github.com/stripe/stripe-python"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/requests-0.8.8"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/unittest2
+ dev-python/mock
+ dev-python/pycurl
+ )"
+
+DOCS="LONG_DESCRIPTION.rst"
+
+python_test() {
+ ${PYTHON:-python} -Wall setup.py test || die
+}