summaryrefslogtreecommitdiff
path: root/dev-python/strict-rfc3339/strict-rfc3339-0.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/strict-rfc3339/strict-rfc3339-0.7-r2.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/strict-rfc3339/strict-rfc3339-0.7-r2.ebuild')
-rw-r--r--dev-python/strict-rfc3339/strict-rfc3339-0.7-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/strict-rfc3339/strict-rfc3339-0.7-r2.ebuild b/dev-python/strict-rfc3339/strict-rfc3339-0.7-r2.ebuild
new file mode 100644
index 000000000000..3dc31a1023ec
--- /dev/null
+++ b/dev-python/strict-rfc3339/strict-rfc3339-0.7-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${PN}-version-${PV}"
+DESCRIPTION="Strict, simple, lightweight RFC3339 functions"
+HOMEPAGE="https://pypi.org/project/strict-rfc3339/ https://github.com/danielrichman/strict-rfc3339"
+SRC_URI="https://github.com/danielrichman/${PN}/archive/version-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest