summaryrefslogtreecommitdiff
path: root/dev-python/stestr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/stestr
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/stestr')
-rw-r--r--dev-python/stestr/Manifest4
-rw-r--r--dev-python/stestr/stestr-2.1.0-r1.ebuild2
-rw-r--r--dev-python/stestr/stestr-3.2.0.ebuild38
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/stestr/Manifest b/dev-python/stestr/Manifest
index aa8a585c73e4..e6336ecfa56a 100644
--- a/dev-python/stestr/Manifest
+++ b/dev-python/stestr/Manifest
@@ -1,3 +1,5 @@
DIST stestr-2.1.0.tar.gz 103501 BLAKE2B 6b000b8e3d0a27a18f19510dd8d5de8641223c18ad22a3f90b73619aa41bbe1a51bcedba604ec448282fa41e2ae93b61fdd0e72e603a39730a59400fc15ef007 SHA512 a99d0659da0ca2b86703529df9ef6d135578bd8374a2afcbd10bd96f24f5e6dd1dacd5929d96a083881f1db2a930b039d9045348a0298d84d2480c6c9a75d1f7
-EBUILD stestr-2.1.0-r1.ebuild 961 BLAKE2B 10cd7f9efa5ccfca094964922f35f425df8476b20140d640f7d1307c41e178b247a6017b7a5a15bd51b5641831b74e5d25db6ac02b6aa9c29479dc66f32b558f SHA512 b931a6ae6b2b3becb60bfa7ff6053c1f3b62cb47c9b1a94eb4b1fecb05a29adc100592c96d0030f1c7a7fd780298ae0a1ffaba63233ae8320e7023ad27b22d87
+DIST stestr-3.2.0.tar.gz 118000 BLAKE2B 901654b53fdc9e5ab287b77b0a26ce531e3a167b2f5d0aa0765de170341bac8ebfbc4efcae39f672ca6dc6f7518913cb5e56d87faaef35c0b06287652c06edb1 SHA512 4f5e41c92518104b06f5b9717d59c214a8d87efe47fee199a602e71efd64e29c98711ffcf3b88cd00209946d0ab123c7ec5aa842e1d54bc65d83c8d70fa4898c
+EBUILD stestr-2.1.0-r1.ebuild 962 BLAKE2B d0387ce2d488ff93dafbcc1a0ef2f92c6b9440b40baaa905d560a8e5591c3981e8433319ad7ee71aeec2429f2d949b02f71341b18c143872fdd77ebd4f230383 SHA512 1f46b2bf824b3782b72f2fdda92241497ec4d8145e9564d42931d6559a68b8c1160fc810ffef3e6ca7f23e79af4a7df332fa3aca5b5da2a82da7973d91d17941
+EBUILD stestr-3.2.0.ebuild 1117 BLAKE2B a02d48df1269f4d02d61d62c1fce7a0829b706171d9ab69d23d56fb37923e1c2a55d38789a0aa665e85642cd7cc41ac467974d152b7eae365fc6ad592689cd8b SHA512 8b0015b4f08cc5fd963a488118ce2847b5e0de2f2fafd09ce40fea7c6c704dd2ee373eabf56b4de63bbeaae85459565525be64168e2ca061d9ce82c05efb5036
MISC metadata.xml 639 BLAKE2B 1a1ae7ac17a9cd8b64fc394ea8d4aede9f7ed1d8142c22eaa88e6315feeeb48e70c074e021dfc8115fce3a8e1b70d0a7739f66e9021e648609d5244548e42f2f SHA512 bcce81b4b21946c4762b334086ba5b72b899f02731de74cfc9bf6a6890bdb0211c7346adb76bc7dbee8edd200392584a1a29bdd5eb6722be1b8a13aeab734533
diff --git a/dev-python/stestr/stestr-2.1.0-r1.ebuild b/dev-python/stestr/stestr-2.1.0-r1.ebuild
index 17c04bb67e58..1de050c25a05 100644
--- a/dev-python/stestr/stestr-2.1.0-r1.ebuild
+++ b/dev-python/stestr/stestr-2.1.0-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
RDEPEND="
diff --git a/dev-python/stestr/stestr-3.2.0.ebuild b/dev-python/stestr/stestr-3.2.0.ebuild
new file mode 100644
index 000000000000..5a1230230549
--- /dev/null
+++ b/dev-python/stestr/stestr-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="A parallel Python test runner built around subunit"
+HOMEPAGE="https://github.com/mtreinish/stestr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.8.9[${PYTHON_USEDEP}]"
+BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing
+ stestr init || die
+ stestr run || die "Tests failed with ${EPYTHON}"
+}