summaryrefslogtreecommitdiff
path: root/dev-python/stestr/stestr-2.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/stestr/stestr-2.1.0-r1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/stestr/stestr-2.1.0-r1.ebuild')
-rw-r--r--dev-python/stestr/stestr-2.1.0-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/stestr/stestr-2.1.0-r1.ebuild b/dev-python/stestr/stestr-2.1.0-r1.ebuild
index 420e4cdb2d60..17c04bb67e58 100644
--- a/dev-python/stestr/stestr-2.1.0-r1.ebuild
+++ b/dev-python/stestr/stestr-2.1.0-r1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="A parallel Python test runner built around subunit"
@@ -14,10 +14,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
-RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
>=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.18.0[${PYTHON_USEDEP}]