summaryrefslogtreecommitdiff
path: root/dev-python/statsd/statsd-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-17 14:32:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-17 14:32:10 +0100
commit51c50bd4c895ebf56d81fecae8e45ec3b5fc3efa (patch)
tree753b6b08624c34d1ed8414bbe22c45409f7741b9 /dev-python/statsd/statsd-3.3.0.ebuild
parentbe9d77d3ac6af8f4ead98d89706f356b65578c93 (diff)
parentdeba8115d2c2af26df42966b91ef04ff4dd79cde (diff)
Merge branch 'edge' into next
Diffstat (limited to 'dev-python/statsd/statsd-3.3.0.ebuild')
-rw-r--r--dev-python/statsd/statsd-3.3.0.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/statsd/statsd-3.3.0.ebuild b/dev-python/statsd/statsd-3.3.0.ebuild
index f92fe942f384..cd01b37d821d 100644
--- a/dev-python/statsd/statsd-3.3.0.ebuild
+++ b/dev-python/statsd/statsd-3.3.0.ebuild
@@ -2,28 +2,21 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
DESCRIPTION="A simple statsd client"
HOMEPAGE="https://github.com/jsocol/pystatsd https://pypi.org/project/statsd"
-
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
)"
-python_test() {
- nosetests --verbose || die
-}
+distutils_enable_tests nose