summaryrefslogtreecommitdiff
path: root/dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild')
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild
new file mode 100644
index 000000000000..9e9c925e0536
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Small convenience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/ssl-fetch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND=">=dev-python/requests-1.2.1[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ elog "This is beta software."
+ elog "The APIs it installs should be considered unstable"
+ elog "and are subject to change in these early versions."
+ elog
+ elog "Please file any enhancement requests, or bugs"
+ elog "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
+}