summaryrefslogtreecommitdiff
path: root/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-23 10:31:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-23 10:31:44 +0000
commit2114f9bc3d55c52f926a43f08765b350871e86f2 (patch)
tree2f8a4e67a8bac41f4090515b87b0135002f10cad /dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
parentfdbd219bffd44c5fa62c89f7dc329673445ee026 (diff)
gentoo auto-resync : 23:11:2023 - 10:31:44
Diffstat (limited to 'dev-python/sshtunnel/sshtunnel-0.4.0.ebuild')
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.4.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild b/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
new file mode 100644
index 000000000000..2f69b50fa02e
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.4.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python SSH tunnels"
+HOMEPAGE="https://pypi.org/project/sshtunnel/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+RESTRICT="test"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"