summaryrefslogtreecommitdiff
path: root/dev-python/sshtunnel/sshtunnel-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/sshtunnel/sshtunnel-0.3.1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/sshtunnel/sshtunnel-0.3.1.ebuild')
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.3.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/sshtunnel-0.3.1.ebuild b/dev-python/sshtunnel/sshtunnel-0.3.1.ebuild
new file mode 100644
index 000000000000..2f97b87074f3
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Pure Python SSH tunnels"
+HOMEPAGE="https://pypi.org/project/sshtunnel/"
+SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE=""
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"