summaryrefslogtreecommitdiff
path: root/dev-python/sqlparse/sqlparse-0.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 23:30:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 23:30:45 +0100
commitf892e24578e434bbea68c4f1c9a8eef429461268 (patch)
tree5fc6072a72fd5ca8397e89183bad49896e6bf372 /dev-python/sqlparse/sqlparse-0.4.3.ebuild
parent0e7ef53ddcc33809bcb2644d3649617113b78ea3 (diff)
gentoo auto-resync : 23:09:2022 - 23:30:45
Diffstat (limited to 'dev-python/sqlparse/sqlparse-0.4.3.ebuild')
-rw-r--r--dev-python/sqlparse/sqlparse-0.4.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/sqlparse/sqlparse-0.4.3.ebuild b/dev-python/sqlparse/sqlparse-0.4.3.ebuild
new file mode 100644
index 000000000000..1aa42718e4ff
--- /dev/null
+++ b/dev-python/sqlparse/sqlparse-0.4.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+MY_PN="${PN##python-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="https://github.com/andialbrecht/sqlparse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${P#python-}
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest