summaryrefslogtreecommitdiff
path: root/dev-python/sqlglot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-28 22:38:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-28 22:38:01 +0100
commitc6a12f3c8604a9269cfb82d666fc716df0e67792 (patch)
tree1e5b7e9357bba635f294047da492297bcb3d65ae /dev-python/sqlglot
parent0c59fd5caa123ae7755b01bb4826776078bf1b81 (diff)
gentoo auto-resync : 28:07:2023 - 22:38:00
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest3
-rw-r--r--dev-python/sqlglot/metadata.xml21
-rw-r--r--dev-python/sqlglot/sqlglot-17.8.4.ebuild36
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
new file mode 100644
index 000000000000..5c02601f7c02
--- /dev/null
+++ b/dev-python/sqlglot/Manifest
@@ -0,0 +1,3 @@
+DIST sqlglot-17.8.4.tar.gz 8373260 BLAKE2B e3b67c940eb608a25705fd280c0165ad7f37db1fcda2f6bc55029af2ad673a789901fbb2e6af72b54d15b75bc84827afadb00cc965efdc3323587278a68f6cf5 SHA512 c1717e7e857ddb9ff700c739b76cd3714e57ae0f7b620593b4fdce53cbf8e37d39882fac1308c3277a236f695292ae1c15541e474d28bdd43d889c2756b172df
+EBUILD sqlglot-17.8.4.ebuild 904 BLAKE2B 2370ebae206d2b7f140a845d67a4b9bf089a1806d6440106f97bccb3c358ca326b6f7e80ce34841bddf62d70af78d1449734011984950950f174cb6b4850d479 SHA512 177fc2f33f8ad55f25dcbd1594f94ae4a5dc6ac95abe65778471db2b258e10d16ea9f4b2e6c2f94d583cc2118d7c7d7635b2a7a6b1b4d0acdb0a381919935c58
+MISC metadata.xml 635 BLAKE2B fb154da2feeea6d590b4f3edb8d8d90d316feee1b8faababc022db026254bd24674d8419b74074b089d4d8930bab642cdc5fa7694bfa9e033cb5ef4ad4988562 SHA512 dd5ed7212dc2eac6a4d84bb2e3639db1ffe163598d911073d7100a8ebfeceb85842ea2e6a597d1036d5b1388d18954b95a782af7b3a84479bf3b59ef9e9b6bf8
diff --git a/dev-python/sqlglot/metadata.xml b/dev-python/sqlglot/metadata.xml
new file mode 100644
index 000000000000..6288bb65af2e
--- /dev/null
+++ b/dev-python/sqlglot/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">tobymao/sqlglot</remote-id>
+ <remote-id type="pypi">sqlglot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sqlglot/sqlglot-17.8.4.ebuild b/dev-python/sqlglot/sqlglot-17.8.4.ebuild
new file mode 100644
index 000000000000..d44b4e19523f
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.8.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/dateutil
+}