summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-30 21:11:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-30 21:11:00 +0100
commitda7cbb075732f5f3eae5a42b6cf53d46caacf85c (patch)
treec75333a842280621a7da87f5738593f4111f2cad /dev-python/sqlalchemy
parent27b0740bf48a0a181090a49d20f368ac8474e90b (diff)
gentoo auto-resync : 30:07:2022 - 21:10:59
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest4
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.37.ebuild97
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.39.ebuild2
3 files changed, 2 insertions, 101 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index 2113d7f94bb4..96742000f2b9 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,5 +1,3 @@
-DIST SQLAlchemy-1.4.37.tar.gz 8155965 BLAKE2B cf21c2ab73a5ba2576a857a12f30ea516265af946e25c1b137e57019d862bf04f4757b4755cee28e6f53642d1f1b58f43c99cd1c69f87640e47ac8a1d1ff8d28 SHA512 3f8a814f9bb6fa273f7b210c4567bf7411d0cf2e5caf010a5387fb946063704c342072145a858fb906545dfb1b959155d041e6073273674e51715356fc1f39e6
DIST SQLAlchemy-1.4.39.tar.gz 8212369 BLAKE2B d65993c4342c2cb5bc76ea4ecc986d0ec521a6eb785604ceeca0c9c22187e4af29fc8bd940a130162ca9dd5c30d58b5d0999472285382c6f6bed3863ff9f20cd SHA512 a7c6b73250044289add492b2d7df9010f3b9a3a5126c8b3448d7339cf743c4be3f1c08d238107bb12c579b2bbd7d20e216e331d3ee10dcf79c0f23ca44d496af
-EBUILD sqlalchemy-1.4.37.ebuild 2839 BLAKE2B b19eea5aad1cb6309d4b8b93777a0dbc9bafce964aea03a3cda6a80acc603fc1ff18cfcf324b6a9a65faf00354f49c778203e02277b8c277dcd484cc381654b5 SHA512 881a5a1b470dcb2c15ce0dead3ea454ec11a130202bb243e14c0622a0d7ab424747b42ac349eb3d7b4f68c27495e273f23d5d1d4c0f8d5fa4cd1efedec785e6a
-EBUILD sqlalchemy-1.4.39.ebuild 2618 BLAKE2B b39513f3fbbe974c80b77ee47efdc7101217d815b2bf501db5800f2661dea9816258da1bdb26deb95c0e577b6c3814b675d496d49c7725e13e073c927091a092 SHA512 3646243bc3cee65f586e1a1ca221761f051161146fb2da54cc396437a58a1cffe3055806bfb336f546731a9cf7987190d911c6b02abbcec4ca78b66c085e4d37
+EBUILD sqlalchemy-1.4.39.ebuild 2617 BLAKE2B 8463ac4ba31b500c01b444cd7b305f2c4dfcc9e39752e68fa0d82b6e7a45a34c55fb72fc87e36035139c714dd5c74fdce6a9f7c9f5c39aa1e4b52b1c0695333b SHA512 53105444a9d92f70b4823ba420d533358c609f6e567911fbe1231eb791d552f6d2a34540718c2ed224b1fdb54d09df7faa04eb9f0684322cb11853b28eadd4f7
MISC metadata.xml 444 BLAKE2B 5fbfcf8f16e52ab5bb691b0b33a8491d94e42a80409114cd9b306af7d4b0eb8b6660fabc663adee53080c635217961301b78df536995b91afe9288d255f73d62 SHA512 b432b65ed3033d34ac0784d007909eb838b309b6a4785eebb1a3f808e43dfc41c786cd55e4dd048776c65127aac170bdd9fb9e5a8ae63accb5f65e300bca9676
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.37.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.37.ebuild
deleted file mode 100644
index 7c460a84d5da..000000000000
--- a/dev-python/sqlalchemy/sqlalchemy-1.4.37.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-PYTHON_REQ_USE="sqlite?"
-
-inherit distutils-r1 optfeature
-
-MY_PN="SQLAlchemy"
-MY_P="${MY_PN}-${PV/_beta/b}"
-
-DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
-HOMEPAGE="
- https://www.sqlalchemy.org/
- https://pypi.org/project/SQLAlchemy/
- https://github.com/sqlalchemy/sqlalchemy/
-"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples +sqlite test"
-
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # hardcode call counts specific to Python versions
- test/aaa_profiling
-)
-
-src_prepare() {
- sed -i -e '/greenlet/d' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # warning tests are unreliable
- test/base/test_warnings.py
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
- )
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # https://github.com/sqlalchemy/sqlalchemy/issues/8019
- test/engine/test_logging.py::TransactionContextLoggingTest::test_log_messages_have_correct_metadata_echo
- )
- if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
- test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
- "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-_exclusions0]"
- "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
- )
- fi
-
- # upstream's test suite is horribly hacky; it relies on disabling
- # the warnings plugin and turning warnings into errors; this also
- # means that any DeprecationWarnings from third-party plugins cause
- # everything to explode
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=
- # upstream automagically depends on xdist when it is importable
- if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
- PYTEST_PLUGINS+=xdist.plugin
- fi
- epytest
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "asyncio support" dev-python/greenlet
- optfeature "MySQL support" \
- dev-python/mysqlclient \
- dev-python/pymysql \
- dev-python/mysql-connector-python
- optfeature "postgresql support" dev-python/psycopg:2
-}
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.39.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.39.ebuild
index 3d537b3f5d7f..e4039b787fa5 100644
--- a/dev-python/sqlalchemy/sqlalchemy-1.4.39.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.39.ebuild
@@ -23,7 +23,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="examples +sqlite test"
BDEPEND="