summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 18:07:08 +0000
commitd46d0aa37cf8b6304aea3c3f2a1be8cca389e989 (patch)
treedbfd9db95941a47b8ecb038ae6792beba39799af /dev-python/sqlalchemy
parent4551b41523452c0d743a71cca34e4dca2ca7538c (diff)
gentoo auto-resync : 04:01:2023 - 18:07:08
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest2
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.46.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index ac3a53a0d6b8..4438ba2fc533 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,5 +1,7 @@
DIST SQLAlchemy-1.4.44.tar.gz 8516775 BLAKE2B 647a43b2c01bcf066891e6bf2247271ff051ebc0d75c2e06b04879d058aacc54dced5d1af00c9489ba515621c56bb6f358836e1658f0069295f125675956797e SHA512 ba4e022f7af77cdf099b59a7af088852d7d4e0b4c6d632a63d244f501ff0b76837e601de63619f219fe50e6d526cd13415c4e623a6127afb0a2f24b87a4c3ece
DIST SQLAlchemy-1.4.45.tar.gz 8535958 BLAKE2B 09e777584067532ed77d8dca9d86996b22317395338aa056d91d7ae1600d6b7111ef714d04980f87ab517007dd6a581c5552efa9c4a676e88c567f339f227fe6 SHA512 4c6e9ef84c6517f47493ad6ce6d366bc0e7222e7a668d43c7b9f4919e87076a5f7687dc525060e430be23c5d9f12e7ef9d97d679040ff132244aa2b3418974a9
+DIST SQLAlchemy-1.4.46.tar.gz 8544238 BLAKE2B 8ef4aae61bee3c9c54b953a9ba34074d8cac0d54d8ae3389f40fa99f57755b2ee0a8a7826e0835fada2d82b96559d974172c9d9781ec746c79006f59d7a5bba0 SHA512 1977c6125e9f45a45b7941c1e0164866bd5ea72839e619d4e259db9a5370fe2b4f191257f3c9ddb28b5c22617a71d359620601c54d9273c38b3281a6c2f5ff03
EBUILD sqlalchemy-1.4.44.ebuild 2860 BLAKE2B 795ce7dee023fcd5750939336554be14c9708eb428a5b1d080326e9aacfc88d3ded80fa0c9afd520f9432bcc0a6520bcd01e98c60b06d3597ac4fbf5f184c1f1 SHA512 720ade94c07bff1c1aa988fcb05166c11df13d3d2e7dc1e3d08e49105736295f4fdd229928a5d844b0ffb34350f947dc679e986f6e77e71618eeb5bfbdd0ffdf
EBUILD sqlalchemy-1.4.45.ebuild 2868 BLAKE2B 5c8f5328cf5e64dd9a551ff4efa944e251d8ac64773c3ef9e3176143cd4dcd7224b15b770c48fe604472833e63d8cfc44aea6c8f5062e5ff0ab941c25a682dc6 SHA512 0482583472e1cc105ed2aacaff50b0126142426ecc5670143969c05fc0a4e250cd74b5b7a09e0d0d0cdb0690aef24fc01b7a3bb4d055cf9724043f3fb71a837b
+EBUILD sqlalchemy-1.4.46.ebuild 2868 BLAKE2B d5770290b02a037c9d38e3a6fb7b25e3a6f5afb9f177cec0ac45ea409e5b66fd41ba1436fb72e6e303f68489d1bb1d1e6eb28d850b565ac38fcccf1bc8e48791 SHA512 b5d48d4f20af46e742724a38902387953431627f4dff08e2119bf69743235c2f813d4816f037dfafea1151d12cbd156bd06bd439f625e58e448f9cb0bd599997
MISC metadata.xml 444 BLAKE2B 5fbfcf8f16e52ab5bb691b0b33a8491d94e42a80409114cd9b306af7d4b0eb8b6660fabc663adee53080c635217961301b78df536995b91afe9288d255f73d62 SHA512 b432b65ed3033d34ac0784d007909eb838b309b6a4785eebb1a3f808e43dfc41c786cd55e4dd048776c65127aac170bdd9fb9e5a8ae63accb5f65e300bca9676
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.46.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.46.ebuild
new file mode 100644
index 000000000000..ebf92044c81f
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.46.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 optfeature
+
+MY_PN="SQLAlchemy"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="
+ https://www.sqlalchemy.org/
+ https://pypi.org/project/SQLAlchemy/
+ https://github.com/sqlalchemy/sqlalchemy/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples +sqlite test"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # hardcode call counts specific to Python versions
+ test/aaa_profiling
+)
+
+src_prepare() {
+ sed -i -e '/greenlet/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # warning tests are unreliable
+ test/base/test_warnings.py
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
+ # https://github.com/sqlalchemy/sqlalchemy/issues/8762
+ test/orm/test_query.py::YieldTest_sqlite+pysqlite_3_39_4::test_yield_per_close_on_interrupted_iteration_legacy
+ )
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[False-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-True]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ )
+ fi
+
+ # upstream's test suite is horribly hacky; it relies on disabling
+ # the warnings plugin and turning warnings into errors; this also
+ # means that any DeprecationWarnings from third-party plugins cause
+ # everything to explode
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=
+ # upstream automagically depends on xdist when it is importable
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=xdist.plugin
+ fi
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "asyncio support" dev-python/greenlet
+ optfeature "MySQL support" \
+ dev-python/mysqlclient \
+ dev-python/pymysql \
+ dev-python/mysql-connector-python
+ optfeature "postgresql support" dev-python/psycopg:2
+}