summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-18 13:56:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-18 13:56:32 +0100
commitcb9a501c2ed1312c376917c1cbfc79542d799806 (patch)
tree007413f26397078db8b9bb4ce69d7499ca5d0a3d /dev-python/sqlalchemy
parenteb17cef883968037fcc6177549d44a030f08b69c (diff)
gentoo auto-resync : 18:10:2022 - 13:56:32
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest2
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.42.ebuild94
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index d9e6b93d4636..19f410183eca 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,3 +1,5 @@
DIST SQLAlchemy-1.4.41.tar.gz 8281227 BLAKE2B 31fb2bfcb41ceefc2c6ed70444b5d8b38a862e06899dd9b5ede7fde0b624ce9f8be766028aaf32b36983268c35e61d87ada5a597260fb97efe72bfc27ce15a71 SHA512 f03a2d4d61a108b4091a4d2ccf2bf49ea22e6c30fcbd70758f89dc3817968e7b5ffa603ce0158812fe42814cd08bbadd00079609a47765d3c534d769835a5543
+DIST SQLAlchemy-1.4.42.tar.gz 8303728 BLAKE2B 8b3a4f1c0931e6182b0251b986d3efb14b032035cb9b6f86fbbd9928f69a12436944c6e5a81aca6ca50dbea76306b14ca8ef68ea36ef82c4b4531498681191a4 SHA512 113e7c5e0949d70091f74271a55722caa1597d65e2e18208691dfd3ff1753b6eec7e69da954958e6dbd34d9c78c022e73bc123d1d1536d27d24f77c044e13621
EBUILD sqlalchemy-1.4.41.ebuild 2690 BLAKE2B 91e714783cea0d60aa2ad38dab70bcb1defdb4db95977958970c9ca14d58a66fd7c88ade7a2f8ef392e32238161c94dc28457288d223a1ccf506fb66f148c46a SHA512 2dbb1cbda431533fc0ca7f554c819c1f190f91b6e2c1c00216009a987fae864046109eb8656ec1b50450e7b70d090719e82a6f3c5dc313c6e05f43e870ffaf7d
+EBUILD sqlalchemy-1.4.42.ebuild 2698 BLAKE2B b1ff340d3abdc039f3d72a031e2157087dbe6eca30d8e56c147c5556366446aad8774665bea45c7f797ff07d016a51edc1282f08d52585f76a7859961fea90f6 SHA512 fca4a89adf8fbf44103d33c0443928c7e368c8a7e0b82bf3c82e5712ae54a25a9b98c2a13d0d751839bd91dcb6ab9f3aca301eddafe1d973d3cb1973f50afac0
MISC metadata.xml 444 BLAKE2B 5fbfcf8f16e52ab5bb691b0b33a8491d94e42a80409114cd9b306af7d4b0eb8b6660fabc663adee53080c635217961301b78df536995b91afe9288d255f73d62 SHA512 b432b65ed3033d34ac0784d007909eb838b309b6a4785eebb1a3f808e43dfc41c786cd55e4dd048776c65127aac170bdd9fb9e5a8ae63accb5f65e300bca9676
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.42.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.42.ebuild
new file mode 100644
index 000000000000..8291064f7c0b
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.42.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 optfeature
+
+MY_PN="SQLAlchemy"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="
+ https://www.sqlalchemy.org/
+ https://pypi.org/project/SQLAlchemy/
+ https://github.com/sqlalchemy/sqlalchemy/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples +sqlite test"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # hardcode call counts specific to Python versions
+ test/aaa_profiling
+)
+
+src_prepare() {
+ sed -i -e '/greenlet/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # warning tests are unreliable
+ test/base/test_warnings.py
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
+ )
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[False-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-True]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ )
+ fi
+
+ # upstream's test suite is horribly hacky; it relies on disabling
+ # the warnings plugin and turning warnings into errors; this also
+ # means that any DeprecationWarnings from third-party plugins cause
+ # everything to explode
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=
+ # upstream automagically depends on xdist when it is importable
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=xdist.plugin
+ fi
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "asyncio support" dev-python/greenlet
+ optfeature "MySQL support" \
+ dev-python/mysqlclient \
+ dev-python/pymysql \
+ dev-python/mysql-connector-python
+ optfeature "postgresql support" dev-python/psycopg:2
+}