summaryrefslogtreecommitdiff
path: root/dev-python/sqlalchemy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 20:08:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 20:08:44 +0000
commit6554f04b9a44e1ffe5d2f614201c11deed2703bd (patch)
tree4a6f98988d23282385c916fa1c677b094d10461a /dev-python/sqlalchemy
parent7c9730bcb62df7cbf8248c5db9a478aac52c60ea (diff)
gentoo auto-resync : 17:02:2023 - 20:08:44
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest2
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-2.0.4.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index 6f98a76aeda3..620bb0897146 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,5 +1,7 @@
DIST SQLAlchemy-1.4.46.tar.gz 8544238 BLAKE2B 8ef4aae61bee3c9c54b953a9ba34074d8cac0d54d8ae3389f40fa99f57755b2ee0a8a7826e0835fada2d82b96559d974172c9d9781ec746c79006f59d7a5bba0 SHA512 1977c6125e9f45a45b7941c1e0164866bd5ea72839e619d4e259db9a5370fe2b4f191257f3c9ddb28b5c22617a71d359620601c54d9273c38b3281a6c2f5ff03
DIST SQLAlchemy-2.0.3.tar.gz 9229747 BLAKE2B b70116a8f9f24ed2b41aa7ebbe8a004371f3aa2e81487bce307157eec8032f134313091455245fe631818a1e6373e3144671f314991408f14b0f0f5f87335290 SHA512 8bf0fa6d95f26fd137690f75e335cf741b8fd19a5a30424e22bb85b79893cbbdc15e206d3f069f202200eb54254df868c4a6d3e74adc1a19e8ce8f92cc407098
+DIST SQLAlchemy-2.0.4.tar.gz 9250723 BLAKE2B c3cec648a527e7beb349b2bbb6924a4e794a1fe4d1563ba7573afdc28ed24fce149c5b3c08fa419e85713b68080b2a805e1999e312f59ed7fae55f9aee6a966e SHA512 098004c594ff00a47a66850b0661f673e4d7a6f168fce72ca37a65ecfe04b3d291b9a6fb9393f7671c9a7c5c128ab6ba2035d18cef28736df1207e689cd8c412
EBUILD sqlalchemy-1.4.46.ebuild 2860 BLAKE2B 8fc052f4930f2369bbbbd336fbfdbf6b2a19b12d51e16f1876262ef1aa344f5d5db75597148a9d46f4144495c2f41a7e735c099bc059c27991f5c4c0c9d73495 SHA512 f043f2491f60baeb6db0055dc2cbe5d0d073e843a9784b8859baebdd37f0300be9b93a83c3910fc0f08e1cd3931b7d35f8a833f8c97f9737f9481dbee6f86087
EBUILD sqlalchemy-2.0.3.ebuild 3773 BLAKE2B 8d2552845792067296728706ecfe99e1ed2b7982fb8fc7ace0a09fdb560bf844c3805425a56cfd5031b4d5518022ce1f065322374a5449217a79235b02cd972d SHA512 6388de896538b9b1de7594fa8696b6a4921465b3b48447e5aec5fd0ed08980886f0be40c5f6d3caa6d2a40aa0fce84c26c75b685ff73793579d907bea6f27569
+EBUILD sqlalchemy-2.0.4.ebuild 3773 BLAKE2B 8d2552845792067296728706ecfe99e1ed2b7982fb8fc7ace0a09fdb560bf844c3805425a56cfd5031b4d5518022ce1f065322374a5449217a79235b02cd972d SHA512 6388de896538b9b1de7594fa8696b6a4921465b3b48447e5aec5fd0ed08980886f0be40c5f6d3caa6d2a40aa0fce84c26c75b685ff73793579d907bea6f27569
MISC metadata.xml 444 BLAKE2B 5fbfcf8f16e52ab5bb691b0b33a8491d94e42a80409114cd9b306af7d4b0eb8b6660fabc663adee53080c635217961301b78df536995b91afe9288d255f73d62 SHA512 b432b65ed3033d34ac0784d007909eb838b309b6a4785eebb1a3f808e43dfc41c786cd55e4dd048776c65127aac170bdd9fb9e5a8ae63accb5f65e300bca9676
diff --git a/dev-python/sqlalchemy/sqlalchemy-2.0.4.ebuild b/dev-python/sqlalchemy/sqlalchemy-2.0.4.ebuild
new file mode 100644
index 000000000000..5aead49e1fbc
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-2.0.4.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 optfeature pypi
+
+MY_PN="SQLAlchemy"
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="
+ https://www.sqlalchemy.org/
+ https://pypi.org/project/SQLAlchemy/
+ https://github.com/sqlalchemy/sqlalchemy/
+"
+SRC_URI="$(pypi_sdist_url --no-normalize "${MY_PN}")"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples +sqlite test"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # hardcode call counts specific to Python versions
+ test/aaa_profiling
+)
+
+src_prepare() {
+ sed -i -e '/greenlet/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ test/ext/mypy/test_mypy_plugin_py3k.py
+ )
+ local EPYTEST_DESELECT=(
+ # warning tests are unreliable
+ test/base/test_warnings.py
+ # TODO
+ test/orm/test_versioning.py::ServerVersioningTest_sqlite+pysqlite_3_40_1::test_sql_expr_w_mods_bump
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
+ test/ext/test_associationproxy.py::DictOfTupleUpdateTest::test_update_multi_elem_varg
+ test/ext/test_associationproxy.py::DictOfTupleUpdateTest::test_update_one_elem_varg
+ test/engine/test_processors.py::PyDateProcessorTest::test_date_invalid_string
+ test/engine/test_processors.py::PyDateProcessorTest::test_datetime_invalid_string
+ test/engine/test_processors.py::PyDateProcessorTest::test_time_invalid_string
+ test/dialect/test_sqlite.py::TestTypes_sqlite+pysqlite_3_40_1::test_cant_parse_datetime_message
+ test/dialect/test_suite.py::ReturningGuardsTest_sqlite+pysqlite_3_40_1::test_delete_single
+ test/dialect/test_suite.py::ReturningGuardsTest_sqlite+pysqlite_3_40_1::test_insert_single
+ test/dialect/test_suite.py::ReturningGuardsTest_sqlite+pysqlite_3_40_1::test_update_single
+ test/base/test_utils.py::ImmutableDictTest::test_pep584
+ )
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[False-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-True]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ )
+ fi
+
+ # upstream's test suite is horribly hacky; it relies on disabling
+ # the warnings plugin and turning warnings into errors; this also
+ # means that any DeprecationWarnings from third-party plugins cause
+ # everything to explode
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=
+ # upstream automagically depends on xdist when it is importable
+ if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
+ PYTEST_PLUGINS+=xdist.plugin
+ fi
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "asyncio support" dev-python/greenlet
+ optfeature "MySQL support" \
+ dev-python/mysqlclient \
+ dev-python/pymysql \
+ dev-python/mysql-connector-python
+ optfeature "postgresql support" dev-python/psycopg:2
+}