summaryrefslogtreecommitdiff
path: root/dev-python/spyder/spyder-5.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/spyder/spyder-5.0.5.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/spyder/spyder-5.0.5.ebuild')
-rw-r--r--dev-python/spyder/spyder-5.0.5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/spyder/spyder-5.0.5.ebuild b/dev-python/spyder/spyder-5.0.5.ebuild
index eb12c15ca98a..27d30b0d5a4c 100644
--- a/dev-python/spyder/spyder-5.0.5.ebuild
+++ b/dev-python/spyder/spyder-5.0.5.ebuild
@@ -46,7 +46,8 @@ RDEPEND="
>=dev-python/keyring-17.0.0[${PYTHON_USEDEP}]
>=dev-python/nbconvert-4.0[${PYTHON_USEDEP}]
>=dev-python/numpydoc-0.6.0[${PYTHON_USEDEP}]
- ~dev-python/parso-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/parso-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/parso-0.8.0[${PYTHON_USEDEP}]
>=dev-python/pexpect-4.4.0[${PYTHON_USEDEP}]
>=dev-python/pickleshare-0.4[${PYTHON_USEDEP}]
>=dev-python/psutil-5.3[${PYTHON_USEDEP}]
@@ -145,6 +146,7 @@ python_prepare_all() {
# The original hasn't been update in over 6 months, and spyder upstream is slow
# in making the switch. Because we are running into issues with outdated deps
# and a whole dependency mess as a result, we can no longer wait for upstream.
+ # Also relax the parso dependency to allow parso 0.7.1
find . -name "*.py" -exec sed -i \
-e 's/python-language-server\[all\]>=0.36.2,<1.0.0/python-lsp-server\[all\]>=1.0.0/g' \
-e 's/python-language-server/python-lsp-server/g' \
@@ -158,6 +160,8 @@ python_prepare_all() {
-e 's/pylsp-black/python-lsp-black/g' \
-e 's/>=0.3.2;<0.4.0/>=0.4.0/g' \
-e 's/>=0.36.2;<1.0.0/>=1.0.0/g' \
+ -e "s/'parso==0.7.0'/'parso>=0.7.0,<0.8.0'/g" \
+ -e "s/'=0.7.0'/'>=0.7.0;<0.8.0'/g" \
{} + || die
# do not depend on pyqt5<13