summaryrefslogtreecommitdiff
path: root/dev-python/spyder/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/spyder/files
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/spyder/files')
-rw-r--r--dev-python/spyder/files/spyder-4.2.1-build.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/spyder/files/spyder-4.2.1-build.patch b/dev-python/spyder/files/spyder-4.2.1-build.patch
new file mode 100644
index 000000000000..38d3356b0b3d
--- /dev/null
+++ b/dev-python/spyder/files/spyder-4.2.1-build.patch
@@ -0,0 +1,36 @@
+diff --git a/setup.py b/setup.py
+index 0c47210..20b95c0 100644
+--- a/setup.py
++++ b/setup.py
+@@ -97,21 +97,6 @@ def get_packages():
+ return packages
+
+
+-#==============================================================================
+-# Make Linux detect Spyder desktop file
+-#==============================================================================
+-class MyInstallData(install_data):
+- def run(self):
+- install_data.run(self)
+- if sys.platform.startswith('linux'):
+- try:
+- subprocess.call(['update-desktop-database'])
+- except:
+- print("ERROR: unable to update desktop database",
+- file=sys.stderr)
+-CMDCLASS = {'install_data': MyInstallData}
+-
+-
+ #==============================================================================
+ # Main scripts
+ #==============================================================================
+@@ -177,8 +162,7 @@ def run(self):
+ 'Intended Audience :: Developers',
+ 'Topic :: Scientific/Engineering',
+ 'Topic :: Software Development :: Widget Sets'
+- ],
+- cmdclass=CMDCLASS)
++ ])
+
+
+ #==============================================================================