summaryrefslogtreecommitdiff
path: root/dev-python/spyder-terminal/spyder-terminal-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/spyder-terminal/spyder-terminal-1.2.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/spyder-terminal/spyder-terminal-1.2.0.ebuild')
-rw-r--r--dev-python/spyder-terminal/spyder-terminal-1.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/spyder-terminal/spyder-terminal-1.2.0.ebuild b/dev-python/spyder-terminal/spyder-terminal-1.2.0.ebuild
new file mode 100644
index 000000000000..370c5f49e104
--- /dev/null
+++ b/dev-python/spyder-terminal/spyder-terminal-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Run system terminals inside Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-terminal"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT BSD Apache-2.0 BSD-2 ISC CC-BY-4.0 ZLIB WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.10.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"