summaryrefslogtreecommitdiff
path: root/dev-python/spyder-notebook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 16:39:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 16:39:59 +0100
commit303f772eff7a30f470d9fb207d69b6a1207b8cab (patch)
treea84db02471adef284e4e5e557037794f024fb1fd /dev-python/spyder-notebook
parentaf951a33bb81b1d784c3f4ea7bb7ca472e5b8d2b (diff)
gentoo auto-resync : 29:07:2023 - 16:39:59
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest2
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.5.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
index deb0ae304e1f..c8338993edbc 100644
--- a/dev-python/spyder-notebook/Manifest
+++ b/dev-python/spyder-notebook/Manifest
@@ -1,3 +1,5 @@
DIST spyder-notebook-0.4.1.tar.gz 1756246 BLAKE2B daccd224f822d10b0bc527f6e12a46b975631c1eee4edd1e431ff8a71e126d4ff2006853b05146bdef3c8978a34a38d1c30ff9da9076f9c954a7ecdbe9eab4af SHA512 f4ad23ba218dec708f876fe13b11e172df2430c9c9e57916a8f10f43f3728788801d7749b37a7474b329fa8750c0d08ddbd5131142035868f23c1975228d840e
+DIST spyder-notebook-0.5.1.tar.gz 5546854 BLAKE2B ccdc93c948e6b4db005cf2433794008c65e9a56574db15cd5627f44938bcc2c865341f2417bcf000e27e3d19fe11b6eb6340e6225a682bf32b2cb06ca8f4605a SHA512 daf91361344f96db0ac855b80d17388bda7bf96eab280fba7ac406915dc9b5283c09e914c07342154ed2d0d23420b5e16923cf4ccddb090364db43cf606319f3
EBUILD spyder-notebook-0.4.1.ebuild 1060 BLAKE2B cecb226af57a5cf5c8c8f6d3ece6449e3953eedc0108b827b2206bd2b2de4b2b391cc7b5d3ba3e35477f373bde00aae7c8b859e59c6db35061c05f5c8f43418a SHA512 f96ac4c73271a7201684ab7f70274ee1bb23fe29933bc1d69e1a1f3c959b2ca3cd900a1278e8f6bb440ba3fd3f6d90fd0e817576e6c12b05f6f6729088fdb09b
+EBUILD spyder-notebook-0.5.1.ebuild 1702 BLAKE2B e65a8007d85d1022d99faecff9fa5a5248b3b19659401d04836392f35c5c051f38b9bb0d50ab3dfeed5cb7c0e908d5ac706b8d6c4dd55c47b5e445f6d4699e9b SHA512 49a49ec2c92b6758fdff4c84b81fd6244869b842db0c4bd276e34c11ddc28142a9417d6613c07f28f62aca873342f29baba79fbe76341292d46471403ce181ba
MISC metadata.xml 427 BLAKE2B 33a2a084ee10c6a4b0646bbd7e866e81e2cd42bbfeb8b2ca1341a19f1af31001a2a34ca8ae5d44b783b5ded83c30b5fdc9e08e626844fd9fb6170b481ab501f4 SHA512 ddd984e2536912410966b76ec42b2a466a100f68a49fe153ce249eaafff9a1feec358292c58495d88cddd588ebdab5fe78c22f4c893194e64defab5a84257fa6
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.5.1.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.5.1.ebuild
new file mode 100644
index 000000000000..a6a5ce291413
--- /dev/null
+++ b/dev-python/spyder-notebook/spyder-notebook-0.5.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/notebook-7[${PYTHON_USEDEP}]
+ <dev-python/notebook-8[${PYTHON_USEDEP}]
+ dev-python/qdarkstyle[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.4.3[${PYTHON_USEDEP}]
+ <dev-python/spyder-6[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( "README.md" "CHANGELOG.md" )
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Hangs
+ spyder_notebook/widgets/tests/test_main_widget.py::test_save_notebook
+ spyder_notebook/widgets/tests/test_main_widget.py::test_new_notebook
+ # Fails in sandbox
+ spyder_notebook/tests/test_plugin.py::test_open_console_when_no_kernel
+ spyder_notebook/widgets/tests/test_main_widget.py::test_shutdown_notebook_kernel
+ spyder_notebook/widgets/tests/test_main_widget.py::test_file_in_temp_dir_deleted_after_notebook_closed
+ # Some missing file
+ spyder_notebook/widgets/tests/test_main_widget.py::test_open_notebook_in_non_ascii_dir
+ spyder_notebook/widgets/tests/test_main_widget.py::test_close_nonexisting_notebook
+)
+
+python_test() {
+ virtx epytest
+}