summaryrefslogtreecommitdiff
path: root/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-25 07:29:14 +0100
commite59b99df9503539c0231e655a17bccf83f8a270d (patch)
treedbd3fc51c710879436a4122898a3653c8c0d4ae8 /dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild
parent9fce2d9787c37a690336f5e345a49d83ee60bc8a (diff)
gentoo auto-resync : 25:06:2023 - 07:29:14
Diffstat (limited to 'dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild')
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild
new file mode 100644
index 000000000000..b67f71095543
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="
+ https://github.com/spyder-ide/spyder-line-profiler/
+ https://pypi.org/project/spyder-line-profiler/
+"
+SRC_URI="
+ https://github.com/spyder-ide/spyder-line-profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-6.0.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}