summaryrefslogtreecommitdiff
path: root/dev-python/spur/spur-0.3.22-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-15 19:51:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-15 19:51:12 +0100
commitca144cbf71b2faf598564847378fa40a0090d67c (patch)
treed9dc05cd474f9feb1649b145b41e453bbebc1ad4 /dev-python/spur/spur-0.3.22-r1.ebuild
parent7b0230b9f0a5cbd2779e7b25d57df8c33b6d0a88 (diff)
gentoo auto-resync : 15:10:2022 - 19:51:12
Diffstat (limited to 'dev-python/spur/spur-0.3.22-r1.ebuild')
-rw-r--r--dev-python/spur/spur-0.3.22-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/spur/spur-0.3.22-r1.ebuild b/dev-python/spur/spur-0.3.22-r1.ebuild
new file mode 100644
index 000000000000..3ae202674b5d
--- /dev/null
+++ b/dev-python/spur/spur-0.3.22-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+MY_P=spur.py-${PV}
+DESCRIPTION="Run commands locally or over SSH using the same interface"
+HOMEPAGE="https://github.com/mwilliamson/spur.py"
+SRC_URI="
+ https://github.com/mwilliamson/spur.py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+ https://dev.gentoo.org/~andrewammerlaan/${P}-nose2pytest.diff
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ # https://github.com/mwilliamson/spur.py/pull/95
+ "${DISTDIR}/${P}-nose2pytest.diff"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # TODO: set up a local SSH server?
+ rm tests/{test_ssh,testing}.py || die
+}