summaryrefslogtreecommitdiff
path: root/dev-python/spotipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/spotipy
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest3
-rw-r--r--dev-python/spotipy/metadata.xml13
-rw-r--r--dev-python/spotipy/spotipy-2.19.0.ebuild48
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
new file mode 100644
index 000000000000..13de582c7400
--- /dev/null
+++ b/dev-python/spotipy/Manifest
@@ -0,0 +1,3 @@
+DIST spotipy-2.19.0.tar.gz 102703 BLAKE2B bc132edb972236b43097c0bbc9d86932a3305d8bd3807e44e20767b123455950b8e01060efd83c87b3a162e329f5c48614205f131686af7f9312a44894a7f1e7 SHA512 fbaecd1a2cab3ef458d30de46cb89462021dfc3cfc85516d8bfe509af016a0b19af2f8de4f5cae36188b1ce1f5718c75edff0e71af2a87f4d720ee99d4541a6a
+EBUILD spotipy-2.19.0.ebuild 1142 BLAKE2B e5758cedfe1043cdd44513808189a9414f51779f213488bf8fd10f047caff435329a1fb4f1e51c731d63e3cacf817c7f2268205cda6d1a46eff49472dcaf00fb SHA512 060ac664853b219996e5fa75f82601c07bdcbf25c657d6a22c17cba3c38c740caa0d5eda4513b336e69c82d4f22209982dcfe37ce8836a416f55968c6409c7d9
+MISC metadata.xml 401 BLAKE2B 431a96f43d9ed792a38755d916c3f50bc0f25be327504226513a9d40cf1632485bd27c83494f8043d629c3827d214db1bda49dc38fe0b648e5498bbcc6ede387 SHA512 d976ffef1ddd34a9d58ed9b5e04aa8d1ba3655b2fd8a7c9d1546239ae8a8763faace560b1eaf2dac91ae58101826b2aa1680123d0f19f66a80a8caac60593522
diff --git a/dev-python/spotipy/metadata.xml b/dev-python/spotipy/metadata.xml
new file mode 100644
index 000000000000..d6cea39e5dcb
--- /dev/null
+++ b/dev-python/spotipy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/plamere/spotipy/issues/</bugs-to>
+ <remote-id type="github">plamere/spotipy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/spotipy/spotipy-2.19.0.ebuild b/dev-python/spotipy/spotipy-2.19.0.ebuild
new file mode 100644
index 000000000000..91857474e8f3
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.19.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A light weight Python library for the Spotify Web API"
+HOMEPAGE="https://spotipy.readthedocs.io"
+SRC_URI="https://github.com/plamere/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Requires user credentials
+ rm tests/integration/test_user_endpoints.py || die
+
+ # Requires a spotify client ID
+ rm tests/integration/test_non_user_endpoints.py || die
+
+ # Needs internet access
+ sed -i -e 's:test_spotify_client_credentials_get_access_token:_&:' \
+ tests/unit/test_oauth.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}