summaryrefslogtreecommitdiff
path: root/dev-python/spotipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
commit1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (patch)
treebe99b6ceb874878a108d68c641b476a2df076517 /dev-python/spotipy
parent0e2a727aba684f1a44cc0402a3f77d242140681b (diff)
gentoo auto-resync : 01:06:2024 - 00:07:06
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest2
-rw-r--r--dev-python/spotipy/spotipy-2.24.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index b48f88cea674..8bf754fa2c10 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1,3 +1,5 @@
DIST spotipy-2.23.0.gh.tar.gz 112399 BLAKE2B 5510ce35624c561df61fffee78f211dfa91ff8d5b3dc15d37c96a51bf830e67aac9c6a0787c71715bee17a3ba91b84766c1ecec37d5775f2182617f2b74a2cb3 SHA512 52955fa3365d5153f19f60874ce8e96910ac8db783499e0e2ef2ab31127277844e24a045115dc522dd7b7535f7907de56da87e02a63b94ee7506b75c1e108e9b
+DIST spotipy-2.24.0.gh.tar.gz 114822 BLAKE2B 0db73d723c1cb3818d68cfa90fd8077c6d6eb82b16f24e087907091d74644b86431aa93ea5ed9a842ec674c16f67cddc5be17a3b6cfcb92d0c01aa8bd3d1529f SHA512 9860119f078ff894a9b27bb4d51cd7b469c2cea4981757338d8c3f1c6c8a1c0bbb3b79622820486c07f0b86ce4e26f9329635b51fc976c4cee43122b9a0209ff
EBUILD spotipy-2.23.0.ebuild 1062 BLAKE2B ad225bc37cceddcfe8ab924420c6b1399631e13f1dea3dec8b39342624ec2c8131dbc05125b40cec735e4c419e20bd7d2a2f7e98de45b3dccd0e2b641693e9f5 SHA512 d26e5a3b95a4576b6fad1b573bf786ac63336313a0944b5b43ed0c107afe62be79017c56f560e1bee9b490d12486bcff51bbd647e728d8a9143956ed8b6e7bc6
+EBUILD spotipy-2.24.0.ebuild 1020 BLAKE2B 9be06f05cfea0eb3391efafb59212cd3c47c69e36cab468bcc183e6e00a60cfd3f261e2e2823312765491464eb48c1e139c4d3fa967ee35252f31198a6bb28f8 SHA512 096d516dfdd43d7c0849440f5b4bb2d07f59421f85ad2c28b420e9cfa4e254776c26664f148316eefa45a36e596423c80379f8a480759f05efc9ff77e35050f2
MISC metadata.xml 563 BLAKE2B 59aaf72f0ef6dcd61187b4d6c4f058725954a01e692fcc3caec5d559a340cf8587950fe96af3c8e10eab4c27ed7a8074cc98ad955b576a261eb8eb9dbe4d6403 SHA512 99afcacd9adfe51850503848dcaebc3d7be85cf50a05dba05ea64c7a9af7d641dbe3db903e611030698f4c7025d99b2057a03e34eca85bc4ac4d811fe961f799
diff --git a/dev-python/spotipy/spotipy-2.24.0.ebuild b/dev-python/spotipy/spotipy-2.24.0.ebuild
new file mode 100644
index 000000000000..7e77086094c6
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.24.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight Python library for the Spotify Web API"
+HOMEPAGE="
+ https://spotipy.readthedocs.io/
+ https://github.com/spotipy-dev/spotipy/
+ https://pypi.org/project/spotipy/
+"
+SRC_URI="
+ https://github.com/spotipy-dev/spotipy/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/redis \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/unit/test_oauth.py::TestSpotifyClientCredentials::test_spotify_client_credentials_get_access_token
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}