summaryrefslogtreecommitdiff
path: root/dev-python/sphobjinv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/sphobjinv
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/sphobjinv')
-rw-r--r--dev-python/sphobjinv/Manifest3
-rw-r--r--dev-python/sphobjinv/metadata.xml23
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.1.ebuild53
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/sphobjinv/Manifest b/dev-python/sphobjinv/Manifest
new file mode 100644
index 000000000000..febd79645318
--- /dev/null
+++ b/dev-python/sphobjinv/Manifest
@@ -0,0 +1,3 @@
+DIST sphobjinv-2.1.tar.gz 1144017 BLAKE2B 71878e1bac5202ab74298b56cd6172236ea524050323e0d6b8bbc0c89f1937d75f10d40b4071cfbe8c9031641e9a0ecb283da908c40840a61c12a7c892438241 SHA512 cde77d73b09b72358b0ac5b0d8f1a748e78dce6664d1b849ba68f5ff70dc43cbcff4581374d0151be29c4d97efe2920c5c00ff68918371243be158031e9554fa
+EBUILD sphobjinv-2.1.ebuild 1374 BLAKE2B 2ef86380cab6b1aa011572f430793e832f20fc7e16073b1a543aa9cbc05977b8e010831f872ca58f4756804886634da6d7badb2bb7a8fecee618195850f49d46 SHA512 ba5d3edebf689ca211e39964486e0eeaccc091b7b609ba05358c32ca48c9ce3593b2ff06163b0412d2f19925807dff48229961e3942a8bd8b1e78f151b5f4b29
+MISC metadata.xml 893 BLAKE2B cf258281d276e039b3eef66ea4612b3b8df3578265939084d02f9743c5aba3a5b27cadcb406f8dab157d9c0b52bea1ed23a71b989ffd20c236d7cb93aa8c52d2 SHA512 87bf6bb4eff58e18e351fd0512c89cca99bb72dfca01dc33b892656a6ef283d3545072bb47a0f1034f27781df1647f3d046440392fd040481b687f75f589d44e
diff --git a/dev-python/sphobjinv/metadata.xml b/dev-python/sphobjinv/metadata.xml
new file mode 100644
index 000000000000..dc83e0f5d0f7
--- /dev/null
+++ b/dev-python/sphobjinv/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <longdescription lang="en">
+Using Sphinx?
+
+Having trouble writing cross-references?
+
+sphobjinv (short for ‘sphinx objects.inv’) can help!
+
+The syntax required for a functional Sphinx cross-reference is highly non-obvious in many cases. Sometimes Sphinx can guess correctly what you mean, but it’s pretty hit-or-miss. The best approach is to provide Sphinx with a completely specified cross-reference, and that’s where sphobjinv comes in.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bskinn/sphobjinv</remote-id>
+ <remote-id type="pypi">sphobjinv</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/sphobjinv/sphobjinv-2.1.ebuild b/dev-python/sphobjinv/sphobjinv-2.1.ebuild
new file mode 100644
index 000000000000..9afca30acd78
--- /dev/null
+++ b/dev-python/sphobjinv/sphobjinv-2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx objects.inv Inspection/Manipulation Tool"
+HOMEPAGE="
+ https://github.com/bskinn/sphobjinv/
+ https://pypi.org/project/sphobjinv/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+# This requires pytest-check, but that does not work at all, even if it
+# is installed it still fails to find the check fixture
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/fuzzywuzzy-0.8[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/dictdiffer[${PYTHON_USEDEP}]
+ dev-python/pytest-ordering[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/stdio-mgr-1.0.1[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues \
+ dev-python/sphinxcontrib-programoutput
+
+python_prepare_all() {
+ # --strict option is deprecated in pytest>6
+ sed -i -e '/addopts/d' tox.ini || die
+
+ distutils-r1_python_prepare_all
+}