summaryrefslogtreecommitdiff
path: root/dev-python/sphobjinv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-python/sphobjinv
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-python/sphobjinv')
-rw-r--r--dev-python/sphobjinv/Manifest2
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.2.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/sphobjinv/Manifest b/dev-python/sphobjinv/Manifest
index 8c83ef3a667f..b2ac286e2f8e 100644
--- a/dev-python/sphobjinv/Manifest
+++ b/dev-python/sphobjinv/Manifest
@@ -1,3 +1,5 @@
DIST sphobjinv-2.2.1.tar.gz 1150428 BLAKE2B 13bec53b00d14466aad652fb822ba32156d4ee3141f2df5bf55eaf77d03627c98c48dd142757ac43fe7dbf00716a85ee4c03060dfcf89e1d9aca4cd2589df5b0 SHA512 9247fc38e5d49adab0921f31e4ad1a8b2ca260c7a921b5fb9db7f800ee484335449031b0f51f81149ff71edba6cc93ab14a683ff6cdce2494322d05474e9a2c7
+DIST sphobjinv-2.2.2.tar.gz 1188094 BLAKE2B f693254f3746b0e5cb6cc863be381f41d26465eab2e1494c29f30f1a72374e8d03dfa5c433958dfa1dcbaa0a7da1ff454c42da5c09011fa67264c26e3623a302 SHA512 36e7667b071f30d4ca066422b21d298c5691321d813ba6ad9eb7a69cd4107ceb18365ee2f95865fad64ab872428b035661a3f513df2e4aab1124b48f49c7280b
EBUILD sphobjinv-2.2.1.ebuild 1538 BLAKE2B c8604ec45bb62d73955f3e65e5a2b8614c63fad40033da95cc72ad7d40cab42b4d9e6b489917c0cb801ea627ed8634f50b9177145b4425ea24b7a507129d7d08 SHA512 029b7303c2cd42b5d0052e146b07d9f776369c031b470546783ed19619c957cf89870ff629d3b093d5cb3989387fac98f3d0fd084262c157928d6aa6a5c51aeb
+EBUILD sphobjinv-2.2.2.ebuild 1548 BLAKE2B d38cf7442a6d10d22e079b5137d483eb9f29a1636b69260e24702977c3fb13197133f464ead429d63b07829d9f56436ce41a412e0a351db4f026ec89d08cdae1 SHA512 088b9cee5d9fa05300186a25ae60a7d471ae033ad6c9999fce5cc38b1f27ba9456d77d4516539f1f76f7bba31405847d2e11f0e4b951f5a5e87832983420cf25
MISC metadata.xml 894 BLAKE2B 9e3b9ad864c23cd1cf346de1c06bf25035de4566733c1716846267aeba3aa09c025e04b15b67369e74f703e4b3205d89e35fd6614627d9f5630fd233320843eb SHA512 f5407da0c6c12279317b17d7174627d1fc3a42f249c1e63acd73c0367c526aab6b62fd358a34760c4986d3d487839905e2ddf5e40c62668933280c5278fefd9e
diff --git a/dev-python/sphobjinv/sphobjinv-2.2.2.ebuild b/dev-python/sphobjinv/sphobjinv-2.2.2.ebuild
new file mode 100644
index 000000000000..fcbe9ae1f403
--- /dev/null
+++ b/dev-python/sphobjinv/sphobjinv-2.2.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx objects.inv Inspection/Manipulation Tool"
+HOMEPAGE="
+ https://github.com/bskinn/sphobjinv/
+ https://pypi.org/project/sphobjinv/
+"
+SRC_URI="
+ https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/fuzzywuzzy[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/dictdiffer[${PYTHON_USEDEP}]
+ dev-python/pytest-check[${PYTHON_USEDEP}]
+ dev-python/pytest-ordering[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/stdio-mgr-1.0.1[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues \
+ dev-python/sphinxcontrib-programoutput
+
+src_prepare() {
+ # --strict option is deprecated in pytest>6
+ sed -i -e '/addopts/d' tox.ini || die
+ sed -e '/CLI_TEST_TIMEOUT/s/2/20/' -i tests/test_cli.py || die
+
+ # remove bundled deps
+ rm -r src/sphobjinv/_vendored || die
+ sed -i -e 's:sphobjinv[.]_vendored[.]::' src/sphobjinv/*.py || die
+
+ distutils-r1_src_prepare
+}