summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sphinxcontrib-spelling
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest5
-rw-r--r--dev-python/sphinxcontrib-spelling/metadata.xml8
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild46
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild40
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
new file mode 100644
index 000000000000..8678904e85db
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -0,0 +1,5 @@
+DIST sphinxcontrib-spelling-2.1.2.tar.gz 35411 BLAKE2B 9738e18664fb68f6f8f7aafb626b6712f7c30947681f6c5ed288dd76c2b24245cb4083887330fc05ef4fdc64756245d997797ae36899c2c762489fff13219a21 SHA512 993f371e064e8748eb61faae649fb293b154a35955ff84d86fd041f4e2cc4c6e22c686007a67c3b63b0c50fc01ed226708f27db347e58847a46ca733c997d51f
+DIST sphinxcontrib-spelling-2.3.0.tar.gz 35687 BLAKE2B 9b48f1953616875bd5f0106ab0a01ac22d176b93eca88da7e36804eaf744aaf6e941d3dcb9f905f9bfe54ea51eb5c0d14d954b3def809994e7ba661e09cdb18e SHA512 194023d2c5ba594a264740a2a45ebd90d37fc17fbd3bc8c53fa303581a652c58332f998a159c9c6c58718dd9898c9b4639e98ee114a2ee1e5f2097e545134a1a
+EBUILD sphinxcontrib-spelling-2.1.2.ebuild 1001 BLAKE2B 2a29736fe88fef6adbf8aa3f8b9b9351579a7ab699def77ccfb319e3bc51fca6f4b9dcf43148098fee63f8b2ddba139ff6a03af655a25d0f6dd8f1b22362f090 SHA512 9a8e53ab29256122f6c8f66fdf3ff9b80384234bffde56c3ad9d563d64a334e9e9ebbf8c7650d7c5b67eba228ee539a6c3757d0ed595edd8c23435bb3629523f
+EBUILD sphinxcontrib-spelling-2.3.0.ebuild 971 BLAKE2B 9e0c91319299cc1d5edbb2f559d4afda4f31c20920e79e6b3157bddd1b7632700f0ae307e3cd9c1c12aa3462adff74ae95fbce14695616e2ef637307da5f95cc SHA512 3f06b34566d2bfe98154a33e32a99965e25110d1619dd8bbd78f1698c53e749b18336be000e5766db6a2e1e8ff0fcbc8b556bf398f9375817e3820b9da5f4cd4
+MISC metadata.xml 299 BLAKE2B 2723daae5f4870ee334a53aeedc5172034e5ad084b91369515b36e010e4e63a436a1967ec5e47fb0a7c57a4a440f2f616639aec965d5c1a5bc1460bf702b47dc SHA512 18274fbc4f1f75db3554f10ff652bad19076f694aa877b2e8135052655f5d41bd3ead6d2ae3aac9c5debc72fdaa746d9508de96d0719e91f83bd2fc6ab797f3e
diff --git a/dev-python/sphinxcontrib-spelling/metadata.xml b/dev-python/sphinxcontrib-spelling/metadata.xml
new file mode 100644
index 000000000000..0269c4fb8409
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-spelling</remote-id>
+ <remote-id type="bitbucket">dhellmann/sphinxcontrib-spelling</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild
new file mode 100644
index 000000000000..066a206f23d4
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://bitbucket.org/dhellmann/sphinxcontrib-spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pyenchant-1.6.5[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-0.6[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
+ test? (
+ ${CDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild
new file mode 100644
index 000000000000..b98bdbe2bdab
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://bitbucket.org/dhellmann/sphinxcontrib-spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+CDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}