summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/sphinxcontrib-spelling
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest2
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index f814ab0f791e..0c595f5591a1 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-spelling-7.2.1.tar.gz 49584 BLAKE2B 7211acfe344b157c0d44f356aef4c31fabcb1b30256cec1693fa67d2652d80c8f3657441c193f82ef26e0e7acd7d141732bef0704462a292355d70a18ab3c2be SHA512 e9b9709b627545e1191d64753c97c0cf65e100d5379e7cc1da46faf9c5d5ea0eeb6c7aafe99331f9518488fb0801c245e0c1fa9853360bb6cf373515a4fed2ed
+DIST sphinxcontrib-spelling-7.3.0.tar.gz 49853 BLAKE2B 3bf7c6433a5de6b109891f1546f109ce7dc5870c0932f49a2dfbc1356c365ba48f885af21e0873284112d8b7b67dbb24730373a16e6786ba7e15f2bc23dc8360 SHA512 25b1902547e4ed172ec437aca0868f458c60aab8dacbeeec7ec1c57a93716672986b815aadb9c129fc6b068b5e4d7e96f6200160c0b688e67314abf290e4ff17
EBUILD sphinxcontrib-spelling-7.2.1.ebuild 1091 BLAKE2B 23635ac63b9beb80c4f7203856d2175f478421f5c2c9f1e906a7403063571f767d7291491054db6a434d7c31429925d697c67583bc61f64a99506b194d45e69a SHA512 2c1d241cd97a2e665a855e13a01c2ddd5542b9ab21da2525bccb2ed8a9e040effa87acf123946bd0b9b8c668119cfd59faaa42822f5d83e80c6b749feb60b43d
+EBUILD sphinxcontrib-spelling-7.3.0.ebuild 1097 BLAKE2B a01212e0e871fdc5b58a03813ac93fb33e5d1c4137061bc94ed0f6b5a1edf27fb330ca69792af96549f24716eeb11b94d75cc7b781bfb774dc665f4b33e49ae9 SHA512 e37a45f9ae5b8a0bc68a61b3ae714ae4df1ae2df4e0e3d210d6d2190ef9bac14c00f73f2f63cc5a745a72c7d9edce420f5a5022a588b49f678a417081106d513
MISC metadata.xml 451 BLAKE2B fa659ac4949e98ca8c5a11a9b72ecba8a69ca94d95f8ab5f07c0d43d9684cd1cd21dbd63f42928a9920001904a6f75aa5663a3d924b02910c78b7894f6011722 SHA512 fead100dcd4c1d85e29260a60178e1b866ceb1f944c73fffcc051e2cfb1e96cc2e61bcf94379c0dcf84bed1349abaceb86ca9a89f2b1a8ddd384c14997d1a159
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.0.ebuild
new file mode 100644
index 000000000000..1bbda9a87600
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+# The doc can only be built from a git repository
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_filter.py::test_contributors
+)
+
+# We don't want distutils_enable_tests to add the namespace
+# package to BDEPEND under "test?". Therefore we add it to RDEPEND
+# after running distutils_enable_tests.
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}