summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-qthelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/sphinxcontrib-qthelp
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/sphinxcontrib-qthelp')
-rw-r--r--dev-python/sphinxcontrib-qthelp/Manifest3
-rw-r--r--dev-python/sphinxcontrib-qthelp/metadata.xml11
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.2.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/Manifest b/dev-python/sphinxcontrib-qthelp/Manifest
new file mode 100644
index 000000000000..cd6b092bce55
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-qthelp-1.0.2.tar.gz 17804 BLAKE2B f3d6a67469c82e2a6e90b75d506ee3faa896d8ec408d60f93f74c8cc4bafb22772f85e36c286a96cecf2d7808338da233910055404969ef311f935173f06f376 SHA512 8fe840e011fabd596194f539d27a502b77ae8a6030ae1a7646b1af9f203d3578b7420ead655297b2a752f0cb0e6803247c7a79b2ccd2d4662ed9f58398947864
+EBUILD sphinxcontrib-qthelp-1.0.2.ebuild 759 BLAKE2B f82067d5c20003acd821876189c986eacdc4077676c622da084b747fc60e78c8c599e1bc47b6c93e240efdbb67b71531e0d2fda17276703b994a27ea3f0ea9b7 SHA512 6cbf4147439ce2df18536ef6d6bee076f93c891436648c9c37539a599608a42278576601a889d5561242cef537043e29eb45a51b6ec82083db95546f8455aa54
+MISC metadata.xml 323 BLAKE2B 958abf4a10551f32a30bf4a103bf38f001d827dad8f8b7c0d737cd8d6cd5a1a7bd4bb0de765ef457875bfedc913a9303fbb94d4f8f796dd6114b1c15a3849b3a SHA512 5b1be7c4599df98adaf5c3b08b078cd15c207957c5e8e7025181be66f09cfe3331b0e1c53404c10041612c34e3cb0af388f1b1c34e3e508b609721c617dc89d6
diff --git a/dev-python/sphinxcontrib-qthelp/metadata.xml b/dev-python/sphinxcontrib-qthelp/metadata.xml
new file mode 100644
index 000000000000..a830ee0b076f
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-qthelp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.2.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.2.ebuild
new file mode 100644
index 000000000000..e9c1a10e87b8
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND=""
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}