summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-24 00:07:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-24 00:07:11 +0100
commitaa4954f71a3ba2293395a8cce2321a70c39c7554 (patch)
tree35665855d8a569dca2bdf52a7316e2503df68208 /dev-python/sphinxcontrib-plantuml
parentb3b92de25c3fc5f6bddc5e513027140591a0b2a5 (diff)
gentoo auto-resync : 24:05:2024 - 00:07:11
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml')
-rw-r--r--dev-python/sphinxcontrib-plantuml/Manifest2
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.30.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/Manifest b/dev-python/sphinxcontrib-plantuml/Manifest
index c9f965e01fe6..cb67c95c0ff7 100644
--- a/dev-python/sphinxcontrib-plantuml/Manifest
+++ b/dev-python/sphinxcontrib-plantuml/Manifest
@@ -1,4 +1,6 @@
AUX sphinxcontrib-plantuml-0.29-pytest-8.patch 1344 BLAKE2B ff992e7101e393cd230952958d4ad4c66bff4676971030690d66317778de72a2df4813bd9260e8466df924b20b9cb8532691a98b1a91aebc8d5f1bc257fbbcd7 SHA512 d12d62fdb4800e7a9538ea2a7235bca8e0d94a1c0144d633a7bea940a54190581c04116a9c2615b21c19b5318dd0a7db21f8f9c05bc0fc3532ad5c8e4397f8b6
DIST sphinxcontrib-plantuml-0.29.gh.tar.gz 19376 BLAKE2B c410be6af6364e347dd1b8e782e55d9cea1c799dc3e2d5055c893b37e437c5e300cafc79e70947447979fe4b11d97fab7cddd6e0894654e274cd05cb5d4abba3 SHA512 9bcec86db5956dd9cbad097ad52b5dc915598c3324662491229268689c3c57c5ce680b38e38ff3360a109f3fd50753c92252ecaf928b124f9a515f52d1da93b4
+DIST sphinxcontrib-plantuml-0.30.gh.tar.gz 19378 BLAKE2B 1f146b59184acec99ff4320199943b2193c3e4c5f5d1f62c6741fb9bbd9802d7c3955bfad786bf7dd4b937b99b974f94d753212c95e7940ab066a9d6ee02af9a SHA512 e85c6332d26d09531c961f8026c72cd82ff4a31700a38cb8285f24d942340700012c08cc1f87a86389b71bfc5d32164586407b5c6777cc94d4d0022c9872ee3a
EBUILD sphinxcontrib-plantuml-0.29.ebuild 1202 BLAKE2B 6476e9ea59b18c96633728140d8b4d54b614837d19d5a62b96e4d8e38f19d7cacb5f1210ed0d7d38fdb5d52d96146541c05ae05f0d9322c54863b8defe9aeed3 SHA512 6c02f117581681028d3440d26003d833fdc3416693f8c94f4c25d78fdf65178b0e317bd50bd37a6a65f49d485f733ef4996f7ec57b0dec592c5c199b741beab2
+EBUILD sphinxcontrib-plantuml-0.30.ebuild 1062 BLAKE2B c9b6a9ef0eca05a884c78b3effc86fe7a0f40647f4d95547ef7dfd2dc35b18c5bd21db43bd94c8fae17086b2112abe12692d798616b920560578143ee5c9efe7 SHA512 c5bb40b5f8ef46e009e9fec46146da53f689a89b3c966bbbd31a5f46a22349b0b81d722890639f708e4deee0a73ec1d3fd5280086a19d811796b129363573d3d
MISC metadata.xml 419 BLAKE2B 05ba888453b1a19e83a8d21a5b0cc2a5a24482434b44c0f3bd4c75c99004523f6397a7a32811a336c15449ea86f1736e5a940d240d19f3956a176fce3881378d SHA512 6d8c4c646e7d84771a7ac7889650c06a0efcaa708d5e009df323f4d8ee591c75d864811ba10dde72b84f40359092302225a93d8de374da8d52033163356d6f46
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.30.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.30.ebuild
new file mode 100644
index 000000000000..e303060263ca
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.30.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/plantuml/
+ https://pypi.org/project/sphinxcontrib-plantuml/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}