summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-21 23:40:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-21 23:40:13 +0000
commit51012ef0261a9da2e4487144906632d06607d3b9 (patch)
tree4bdd7443f88209d056985f2e4748277714e35829 /dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild
parentf2d1966a40070fb5ba3279db49b8435c7c143802 (diff)
gentoo auto-resync : 21:02:2024 - 23:40:13
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild')
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild
new file mode 100644
index 000000000000..74c22f4418d0
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.28.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/plantuml/
+ https://pypi.org/project/sphinxcontrib-plantuml/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ epytest
+}