summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-31 21:49:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-31 21:49:19 +0000
commitb43ae231a57eccda208f33c4343d956e7f2590f5 (patch)
tree8871b66b51dfb514ef803c4eaf3d1f2cb57c4ee1 /dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild
parent7e84f2c47ae7a0e8b76fc3080b1c7ee8487ee76b (diff)
gentoo auto-resync : 31:10:2023 - 21:49:19
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild')
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild
new file mode 100644
index 000000000000..d4636449c967
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/plantuml/
+ https://pypi.org/project/sphinxcontrib-plantuml/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ epytest
+}