summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-15 21:27:56 +0100
commit3648761f2708fcf5662ea1b9585f594c36eefc30 (patch)
tree7b8af3caaff06cdddb5c39ec135ecc908b62a139 /dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild
parent4214d835b45f0047c644e43c7fa70f1bbdb2e8b3 (diff)
gentoo auto-resync : 15:08:2023 - 21:27:55
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild')
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild
new file mode 100644
index 000000000000..64208ead486a
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.25.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="https://github.com/sphinx-contrib/plantuml/"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ epytest
+}