summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-log_cabinet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-python/sphinxcontrib-log_cabinet
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-python/sphinxcontrib-log_cabinet')
-rw-r--r--dev-python/sphinxcontrib-log_cabinet/Manifest3
-rw-r--r--dev-python/sphinxcontrib-log_cabinet/metadata.xml13
-rw-r--r--dev-python/sphinxcontrib-log_cabinet/sphinxcontrib-log_cabinet-1.0.1.ebuild23
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-log_cabinet/Manifest b/dev-python/sphinxcontrib-log_cabinet/Manifest
new file mode 100644
index 000000000000..72b996f8aad0
--- /dev/null
+++ b/dev-python/sphinxcontrib-log_cabinet/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-log-cabinet-1.0.1.tar.gz 4072 BLAKE2B 6e237bee5ddcd13dfa0cf5151446a1d3924534009cf8c4b11c064dc454e0687ed03e9b09052332bf8c299d340a3522718704d65ac0fd7bd5eb22d18403b3b369 SHA512 c8529872c4ee783330738babd5027e64a813698ed38fbc693b23e65e5bfa2be815a7e6acfae42bbe003e542002d7d298ee446cab5dcebb3b65d2a25691bde18a
+EBUILD sphinxcontrib-log_cabinet-1.0.1.ebuild 647 BLAKE2B a70f37a382668bd37b47a3c7b48260bb4f8e3723302727ed52008405e053c60d26f07634bf68f238ddca6308628b9029b6a4e4c12ebf48b06f76444c6782509f SHA512 e3ea7ef1c5a7a874c564ed3673aa05a9ac957e891a44fe19f7b01fa7086cc617b7dde546f862dab21a8f100fa3b4d0b6ebc960604b782095340daa4e17bc00e2
+MISC metadata.xml 426 BLAKE2B a4266e6638e558f85936fa16c72482ed331b3182fac2a42023cd94a4f965423569cd968e103f68a295a5444802778d550b39796421c4053abdf69c154fa7da9f SHA512 8a966aafc4c4e7c53079e41d633dfa5f0cf7931f60ec8e361f5900dd286ec1d25439ca7ba537ec555dca183dbe6de8da0fd521b0ca60792e31d2bd3e4951c95b
diff --git a/dev-python/sphinxcontrib-log_cabinet/metadata.xml b/dev-python/sphinxcontrib-log_cabinet/metadata.xml
new file mode 100644
index 000000000000..4559300f4dac
--- /dev/null
+++ b/dev-python/sphinxcontrib-log_cabinet/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-log-cabinet</remote-id>
+ <remote-id type="github">davidism/sphinxcontrib-log-cabinet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-log_cabinet/sphinxcontrib-log_cabinet-1.0.1.ebuild b/dev-python/sphinxcontrib-log_cabinet/sphinxcontrib-log_cabinet-1.0.1.ebuild
new file mode 100644
index 000000000000..8b023c460f55
--- /dev/null
+++ b/dev-python/sphinxcontrib-log_cabinet/sphinxcontrib-log_cabinet-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Organize changelog directives in Sphinx docs"
+HOMEPAGE="https://github.com/davidism/sphinxcontrib-log-cabinet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}