summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild')
-rw-r--r--dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
new file mode 100644
index 000000000000..62cfbf4fe443
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Adds example directive for sphinx-contrib httpdomain"
+HOMEPAGE="https://github.com/collective/sphinxcontrib-httpexample"
+SRC_URI="https://github.com/collective/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/astunparse[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-httpdomain[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/snapshottest[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:pytest-runner::" -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests fail with ${EPYTHON}"
+}