summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch')
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch b/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
new file mode 100644
index 000000000000..a45ae42b188a
--- /dev/null
+++ b/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/show_bug.cgi?id=429914
+--- a/setup.py
++++ b/setup.py
+@@ -1,10 +1,11 @@
+ # -*- coding: utf-8 -*-
+
++import codecs
+ import os
+ from setuptools import setup, find_packages
+
+ HERE = os.path.dirname(os.path.abspath(__file__))
+-long_desc = open(os.path.join(HERE, 'README')).read()
++long_desc = codecs.open(os.path.join(HERE, 'README'), encoding='utf-8').read()
+
+ requires = ['Sphinx>=0.6']
+