summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-devhelp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/sphinxcontrib-devhelp
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/sphinxcontrib-devhelp')
-rw-r--r--dev-python/sphinxcontrib-devhelp/Manifest3
-rw-r--r--dev-python/sphinxcontrib-devhelp/metadata.xml11
-rw-r--r--dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.1.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-devhelp/Manifest b/dev-python/sphinxcontrib-devhelp/Manifest
new file mode 100644
index 000000000000..b62bba7105c7
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/Manifest
@@ -0,0 +1,3 @@
+DIST sphinxcontrib-devhelp-1.0.1.tar.gz 14016 BLAKE2B 4b8c079773d65f5fb752870dc728d8e90e03fdd2f8a4b01324838928ef2deaf2c724c0b149697a61624ea7382445e81fe261ec2b726fa3cfb5547bd053286e4e SHA512 135d6405e330cc245391646d4055988cf762d82f6473e58c64a76f3a88e7f33a66baba366e7f29e1378320bd0c374af92b0f972bceeec8c05ad0fe652a81e984
+EBUILD sphinxcontrib-devhelp-1.0.1.ebuild 760 BLAKE2B 8aebb01d04952eefa7daad168b82ae27b4e87d337b897a07e9e58c1c2751fd65a0fb450cf1b92286d035b8850450c84dcc80f1a5b23328913bc6b1abfee197a0 SHA512 fa90599bd81f7ade52a7c9e870aa227b30e4d822352a0b80581dd398142da11080fb116524b1ceda7c2d3b258197db11975b42a8a0225784b0b80ce4299d45fb
+MISC metadata.xml 324 BLAKE2B 986204c86559fccc9a83332d2a443367be0d3f6d58ee2f50d5119688db2c3bf979aa14ad41979bfe0cabab649594e6d69e83c592a4d883e6d14b4840d3dcdf4d SHA512 d4f768df06e1c208502e7f87ec3ff4481f07ff84fd77721a5afc8a7c3bb7804a17a6a5798bc056e384d2ce433954790403c0d5d5cbba459ce835659bf8072a53
diff --git a/dev-python/sphinxcontrib-devhelp/metadata.xml b/dev-python/sphinxcontrib-devhelp/metadata.xml
new file mode 100644
index 000000000000..56e1912641fe
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-devhelp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.1.ebuild b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.1.ebuild
new file mode 100644
index 000000000000..be40fb0be2d7
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs Devhelp documents"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND=""
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}