summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-blockdiag
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/sphinxcontrib-blockdiag
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/sphinxcontrib-blockdiag')
-rw-r--r--dev-python/sphinxcontrib-blockdiag/Manifest4
-rw-r--r--dev-python/sphinxcontrib-blockdiag/metadata.xml14
-rw-r--r--dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild39
-rw-r--r--dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5.ebuild33
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-blockdiag/Manifest b/dev-python/sphinxcontrib-blockdiag/Manifest
new file mode 100644
index 000000000000..7ef6d552ce67
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/Manifest
@@ -0,0 +1,4 @@
+DIST sphinxcontrib-blockdiag-1.5.5.tar.gz 12066 SHA256 eb9085b7125b2f33e3f33770733cdc470a3404c40e6a251cc8b624e5e25c295c SHA512 4c007e2c394bf90ff84a000cf44ec1d50b39286a32929c89a64320299a70f10e44da35d942e7bb8697a9d61eb6a551f74bd15349cf0b439369aaaf12d175635a WHIRLPOOL a50fe5c5abbd77dbcb4c19815d974ab22f620a5075ef954b4a30f8294671d7ddd1666c0222c05162377e5c48e6380e01674acd0a7454f38095171000da43b82e
+EBUILD sphinxcontrib-blockdiag-1.5.5-r1.ebuild 864 SHA256 2a14dd457a550f6206b3ddfbd7de6ea0732c10cae06e9dcb8557c4d716dfe670 SHA512 d8abca6cf6e8c8633f9ce872531a7c3be58362fa1135bb1d51591dfb61751b4d1cb767494641a5b393d6b594ab4ff0582a9a7483827b084fb419121078998b8f WHIRLPOOL 679f642e1d0d6959a57a957719235818439d15fe7644fd6b788e818de48bfbea025d997892660f37989225dafa604cb69ac2ae25fedfafa58f52210cdccdfc81
+EBUILD sphinxcontrib-blockdiag-1.5.5.ebuild 679 SHA256 25f4c4d28e2cbe6fa9e447045159c14cd1309d43fc6bdf0faf856f4d2fa28d3c SHA512 1a1b68c4dbb051f35f19a05bec35103192111df977afa688e90b185a36a3676c6bcfda5a2160499edf6141b6220f709d08ba4d809fe727f7f13a2c2b0d31c2ed WHIRLPOOL ea661229e4c4eec71ddc936fe18af0fda04d102856d4c45e3b3f047ad2f8c2224dd7c773cce2586b2cba2e7fc7b52a41fbc634f610ae8a2d8a114a78ff3cab9d
+MISC metadata.xml 415 SHA256 e4e8cca40d49fbc5affa74a89c4a4dd6a480dc3fed03cc62698b09de336ffe4b SHA512 857a231d759fecabeaa764a2ec8181788f5ae4d9271414f75d001ef60b0a146f533a277dd6473678d398013fbde58c4f0479291089653a521d30cc1931f7da89 WHIRLPOOL 0590669e0a33dbb06675cac42084ca88c733f98061b62028cb603b3f246baaeccf08fa49afaafb3864c50f96a4905d2f9e1c70811a8fef1744cd6e676958aea7
diff --git a/dev-python/sphinxcontrib-blockdiag/metadata.xml b/dev-python/sphinxcontrib-blockdiag/metadata.xml
new file mode 100644
index 000000000000..c0b469c17c97
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>i.tkomiya@gmail.com</email>
+ <name>Takeshi KOMIYA</name>
+ </maintainer>
+ <remote-id type="github">blockdiag/sphinxcontrib-blockdiag</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild
new file mode 100644
index 000000000000..775f0da1e163
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
+
+HOMEPAGE="https://github.com/blockdiag/sphinxcontrib-blockdiag"
+
+SRC_URI="https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e /build-base/d setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5.ebuild b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5.ebuild
new file mode 100644
index 000000000000..c2d09ca7e7df
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
+
+HOMEPAGE="https://github.com/blockdiag/sphinxcontrib-blockdiag"
+
+SRC_URI="https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE=""
+
+DEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -i -e /build-base/d setup.cfg || die
+ distutils-r1_python_prepare_all
+}