summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-blockdiag
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/sphinxcontrib-blockdiag
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/sphinxcontrib-blockdiag')
-rw-r--r--dev-python/sphinxcontrib-blockdiag/Manifest2
-rw-r--r--dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-3.0.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-blockdiag/Manifest b/dev-python/sphinxcontrib-blockdiag/Manifest
index c4fb8104320c..42d1232096e4 100644
--- a/dev-python/sphinxcontrib-blockdiag/Manifest
+++ b/dev-python/sphinxcontrib-blockdiag/Manifest
@@ -1,3 +1,5 @@
DIST sphinxcontrib-blockdiag-2.0.0.gh.tar.gz 11903 BLAKE2B 9301fe05ff936836e8e648a507b7e2e5fd8cada58252fd46b274a4bb3e6b51b00b7696ceee712d12bd590c40c5ae1235e0b532ef55ffc2e78b2986cdae64a0f2 SHA512 305ad9b27bbb44480c69139cc0ae9cd8e47c6ad95da5b14a964c703a17e62ab9b342ff567e8312e403549a794f6381fe4c4d444ccb7a8e41410d1a3754ffb3f1
+DIST sphinxcontrib-blockdiag-3.0.0.gh.tar.gz 12300 BLAKE2B 4bb6e83625095aab209b3f8eff3f96dd0c0ff37c542bedd03d7b56be282bdb6929bba7ef9cbbc458492b17bfbcf80d705cb17b3f194213c1416bf1ab090fcc6a SHA512 1d03296007b0b6455fa25b1c0d3f09fb76dfaeba43ac7155033ec6fda0aaae40b757f6b77b63725489f2360eb5a80ce8e9e55eb6460b73c3b3bca363afe8aeac
EBUILD sphinxcontrib-blockdiag-2.0.0-r1.ebuild 1227 BLAKE2B 4111c11961945fa16b5e326014eaecb3d88b806a50eb2e377ddc94dff954497b6008d83e43313ce6f18306600ce9a41c74473a080648f977e3afa11f4469029f SHA512 2b98094fc3ebb15babf69712ac9a932b746ff126bf2f4c7f3628e693c47780c2b148f79be4e6b152294a8234d49eed1e7d448970fd7241b1abf7ed7e2fd3bfb5
+EBUILD sphinxcontrib-blockdiag-3.0.0.ebuild 1186 BLAKE2B 393b3b9201548d4b45e0b0e3bb8645b7d6d61984091e63583992ec59e45b03b4faeed12aaa695955bf6763ab5ea479149b3e367bf8f6cc2a360a4460b98fa385 SHA512 ce0cc97731545acaeecdca638f98d51e8815a2a80fc3d138fc7791701908c3382bb1ba5c3848ed965a5bfc6231753ee7df0c7f413db7bf6adaa3ebc0d467bca1
MISC metadata.xml 502 BLAKE2B a9910c9ee4029937c23f98b7cab1b6d9b2ca72db3272fab0c11d8e3e851e249229a2749d74250c8717e83d90eab0613cab892e7218b70ab26b761a77c23bd4a8 SHA512 993ab6e8cd639af61f08bffe017bd6d12539d20f827b1992a8d99e9cbcc6cfb18b254b2b7a86ce16a2b87125254d801333f68469bc6bc6b576a70d27c605c6a4
diff --git a/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-3.0.0.ebuild b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-3.0.0.ebuild
new file mode 100644
index 000000000000..63bb84ea4cc5
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-3.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
+HOMEPAGE="
+ https://github.com/blockdiag/sphinxcontrib-blockdiag/
+ https://pypi.org/project/sphinxcontrib-blockdiag/
+"
+SRC_URI="
+ https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e "/build-base/d" setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ rm -rf sphinxcontrib || die
+ distutils_write_namespace sphinxcontrib
+ eunittest
+}