summaryrefslogtreecommitdiff
path: root/dev-python/sphinx_ansible_theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/sphinx_ansible_theme
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/sphinx_ansible_theme')
-rw-r--r--dev-python/sphinx_ansible_theme/Manifest3
-rw-r--r--dev-python/sphinx_ansible_theme/metadata.xml13
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.6.0.ebuild20
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinx_ansible_theme/Manifest b/dev-python/sphinx_ansible_theme/Manifest
new file mode 100644
index 000000000000..2a186495cd71
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx_ansible_theme-0.6.0.tar.gz 37606 BLAKE2B 3b27d15133e167602ce9515fb630ed9ecb0b0d346450417900e616476fa80aa216c033741121f82289d9e5bf977e01395663e5f61c4682576e8b773c17af2723 SHA512 d134a9e6eab0cab8e60c251a69e7b3dfa2864e5e19d65ce2e8b565a601e4b5255536f6b69ac17952ebd14929471a487200fc97c9c5e1f3f8232daf8e4ed63cef
+EBUILD sphinx_ansible_theme-0.6.0.ebuild 546 BLAKE2B 2cf05a53b73353c25b9bbab9cf6224acf86fa75c7cdd31ca1ac8a2e0adc4fb04f266cbbe4220913628097ab95daac9bbe4b3599c58bc2d8f5d585495c57f0bbb SHA512 0d9c175f59ea2f22d7bc51cab60e9da2076571bed6074ef6ba152d0f9a52e6e595228d86977e38ce2ee6565b69c0210fc587823f283e4ce9b73593117de50773
+MISC metadata.xml 430 BLAKE2B d69493167713787e38b47e62dcf894646cc2df043c2010c543f7f1b608b5511a23cf558752244b6a6ae2521e00c4c1da2cfc33777e5ed71ed3d04844f06eec6b SHA512 518ca67d4193bbfc53851e64bac3be3769677ff987bd0edb3bb102b05e1cd1b3c818f194b5fcdf0471dc6a89bc9d45a393922a5767675818dcdd5303c07d1e56
diff --git a/dev-python/sphinx_ansible_theme/metadata.xml b/dev-python/sphinx_ansible_theme/metadata.xml
new file mode 100644
index 000000000000..0fb924872568
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">ansible-community/sphinx_ansible_theme</remote-id>
+ <remote-id type="pypi">sphinx-ansible-theme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.6.0.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.6.0.ebuild
new file mode 100644
index 000000000000..8b7f8535d306
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.6.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A reusable Ansible Sphinx theme"
+HOMEPAGE="https://github.com/ansible-community/sphinx_ansible_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]"