summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-prompt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
commitc9e9e39938097bf29063c271195ad0d7d7bd02a9 (patch)
treef2f4ab36d22272fec3a1d1313d8f700b1f0f6744 /dev-python/sphinx-prompt
parent0968caae52d6eae7513e2ce4e0900a2e009780ee (diff)
gentoo auto-resync : 17:09:2023 - 17:03:44
Diffstat (limited to 'dev-python/sphinx-prompt')
-rw-r--r--dev-python/sphinx-prompt/Manifest2
-rw-r--r--dev-python/sphinx-prompt/sphinx-prompt-1.8.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-prompt/Manifest b/dev-python/sphinx-prompt/Manifest
index 2528b0091bd4..9c1d9647440b 100644
--- a/dev-python/sphinx-prompt/Manifest
+++ b/dev-python/sphinx-prompt/Manifest
@@ -1,3 +1,5 @@
DIST sphinx-prompt-1.7.0.gh.tar.gz 38317 BLAKE2B b042b7821d16ff63d259b73de476f96cafea32345dc98d24a9abb97dd46ecbd6947862ef727b830c27889f4b8a17c30c8dd86a4bddd38294a3a4bca00349bf87 SHA512 1b0df502c75ea4cac4e4a5b11c0aa762851b82c39892410c97f0ed45bdd74e5706a580a906d4ebb8c47700324c089c5114eba12cd4617aba37cfea8c338ac9d5
+DIST sphinx-prompt-1.8.0.gh.tar.gz 38424 BLAKE2B c469e2acfdad076afd472c30380a59aae4d719edce653794fd4d09a2c8008b7f67642ce2a740fb1408987243ba5d520e28b3dc4d7ec34899de6fcf57f2171456 SHA512 1acaa18066537adaab71eb900f0b0fb8041f8f25a9079e171b98b98106d5b7d1885e23bae2c1fd278bbf22c66d17238fbf386cb61fc5725475862aaf86d5701e
EBUILD sphinx-prompt-1.7.0.ebuild 987 BLAKE2B 4dd4bf32d9f9edc0d928c3707acd3709f24d0bada04681a88cfdebb4c22b0d29dac2c9fa68bc637e3e7ef27cbc6f8079f79dabaf7e6a863abc7890bf4dafa528 SHA512 6fcc8994e136521b5268ab052fe27befb430da04677a2af2e5e15e2062ccc0a47ea89835661d9bd5ef08fd05a6634b1d25f474c5db9602f653b9c2b583d70743
+EBUILD sphinx-prompt-1.8.0.ebuild 1087 BLAKE2B 527397e9edb537e80ebfaa7f73692b8d16efdf1e4054c1676bbd2acf590ee00576701d6c5d7264837c4957fed9f59863cc70f77729cb22c97454d6e7d6c48c92 SHA512 082226daf70f2b0fcc05619eec123833e61de175e5e615105b38efbdbbbda14fb2ed88f1fdb57343034fe7f53da4283305c91ea39ed1895fe18c94db3c650bbc
MISC metadata.xml 416 BLAKE2B 5c9110bc6a6c0c7acab6e9f10d8d84601a66c7741ba15612eb032272db9517f314eec8f86677e43fd7dfb1b032388b1db3b60c64e0cd9a6943498c4715ebf1e0 SHA512 5d23f08978f7ca0dae7062a4a872f1be37969144c128c4a1f2006798465b5dbf95090e14859eb6c7e1e75649170e40fe156e6b9cd5b1263464e88edffc760a15
diff --git a/dev-python/sphinx-prompt/sphinx-prompt-1.8.0.ebuild b/dev-python/sphinx-prompt/sphinx-prompt-1.8.0.ebuild
new file mode 100644
index 000000000000..81b0e33877a4
--- /dev/null
+++ b/dev-python/sphinx-prompt/sphinx-prompt-1.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx directive to add unselectable prompt"
+HOMEPAGE="
+ https://github.com/sbrunner/sphinx-prompt/
+ https://pypi.org/project/sphinx-prompt/
+"
+SRC_URI="
+ https://github.com/sbrunner/sphinx-prompt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # version number relies on git repo, sigh
+ # also all dependencies are pinned to exact versions, sigh
+ # also huge hack to install package as "sphinx-prompt", sigh
+ sed -i \
+ -e "/^version =/s:[0-9.]\+:${PV}:" \
+ -e '/^\[tool\.poetry\.dependencies\]$/,$s:"[0-9.]\+:"*:' \
+ -e '/include.*sphinx-prompt/d' \
+ pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}